commit
510ccee39b
Binary file not shown.
@ -0,0 +1,20 @@
|
||||
--- zip-0.6.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ zip-0.6.6/Cargo.toml 2024-01-05T12:54:04.038663+00:00
|
||||
@@ -50,7 +50,7 @@
|
||||
optional = true
|
||||
|
||||
[dependencies.constant_time_eq]
|
||||
-version = "0.1.5"
|
||||
+version = "0.3"
|
||||
optional = true
|
||||
|
||||
[dependencies.crc32fast]
|
||||
@@ -81,7 +81,7 @@
|
||||
default-features = false
|
||||
|
||||
[dependencies.zstd]
|
||||
-version = "0.11.2"
|
||||
+version = "0.12"
|
||||
optional = true
|
||||
|
||||
[dev-dependencies.bencher]
|
@ -0,0 +1,312 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 3;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate zip
|
||||
|
||||
Name: rust-zip
|
||||
Version: 0.6.6
|
||||
Release: %autorelease
|
||||
Summary: Library to support the reading and writing of zip files
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/zip
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * bump constant_time_eq dependency from 0.1 to 0.2
|
||||
# * bump zstd dependency from 0.11 to 0.12
|
||||
Patch: zip-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Library to support the reading and writing of zip files.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+aes-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+aes-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "aes" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+aes-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+aes-crypto-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+aes-crypto-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "aes-crypto" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+aes-crypto-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+bzip2-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+bzip2-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "bzip2" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+bzip2-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+constant_time_eq-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+constant_time_eq-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "constant_time_eq" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+constant_time_eq-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+deflate-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+deflate-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "deflate" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+deflate-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+deflate-miniz-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+deflate-miniz-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "deflate-miniz" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+deflate-miniz-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+deflate-zlib-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+deflate-zlib-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "deflate-zlib" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+deflate-zlib-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+flate2-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+flate2-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "flate2" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+flate2-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+hmac-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+hmac-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "hmac" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+hmac-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pbkdf2-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pbkdf2-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pbkdf2" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pbkdf2-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+sha1-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+sha1-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "sha1" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+sha1-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+time-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+time-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "time" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+time-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+unreserved-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+unreserved-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "unreserved" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+unreserved-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+zstd-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+zstd-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "zstd" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+zstd-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires -a
|
||||
|
||||
%build
|
||||
%cargo_build -a
|
||||
|
||||
%install
|
||||
%cargo_install -a
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test -a
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.6.6-3
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Sat Jan 06 2024 Michel Lind <salimma@fedoraproject.org> - 0.6.6-3
|
||||
- Rebuilt for constant_time_eq 0.3
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Wed May 17 2023 Fabio Valentini <decathorpe@gmail.com> - 0.6.6-1
|
||||
- Update to version 0.6.6; Fixes RHBZ#2195924
|
||||
|
||||
* Mon Apr 17 2023 Fabio Valentini <decathorpe@gmail.com> - 0.6.4-1
|
||||
- Update to version 0.6.4; Fixes RHBZ#2066114
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.13-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.13-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.13-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.13-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Sat Jun 05 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.13-1
|
||||
- Update to version 0.5.13.
|
||||
- Fixes RHBZ#1968045
|
||||
|
||||
* Wed Apr 21 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.12-1
|
||||
- Update to version 0.5.12.
|
||||
- Fixes RHBZ#1950461
|
||||
|
||||
* Mon Mar 01 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.11-1
|
||||
- Update to version 0.5.11.
|
||||
- Bump to bzip2 0.4.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Dec 07 2020 Fabio Valentini <decathorpe@gmail.com> - 0.5.9-1
|
||||
- Update to version 0.5.9.
|
||||
- Fixes RHBZ#1904876
|
||||
|
||||
* Sun Nov 08 2020 Fabio Valentini <decathorpe@gmail.com> - 0.5.8-2
|
||||
- Relax flate2 dependency.
|
||||
|
||||
* Fri Sep 11 2020 Josh Stone <jistone@redhat.com> - 0.5.8-1
|
||||
- Update to 0.5.8
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat Jun 27 2020 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.5.6-1
|
||||
- Update to 0.5.6
|
||||
|
||||
* Sat May 23 13:25:44 PDT 2020 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.5.5-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue