update to version 0.5.11

epel9
Fabio Valentini 4 years ago
parent 0b797e5114
commit 19f3102cae
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,3 +1,4 @@
/zip-0.5.6.crate
/zip-0.5.8.crate
/zip-0.5.9.crate
/zip-0.5.11.crate

@ -0,0 +1,13 @@
diff --git a/src/write.rs b/src/write.rs
index bc68817..4099599 100644
--- a/src/write.rs
+++ b/src/write.rs
@@ -553,7 +553,7 @@ impl<W: Write + io::Seek> GenericZipWriter<W> {
)),
#[cfg(feature = "bzip2")]
CompressionMethod::Bzip2 => {
- GenericZipWriter::Bzip2(BzEncoder::new(bare, bzip2::Compression::Default))
+ GenericZipWriter::Bzip2(BzEncoder::new(bare, bzip2::Compression::default()))
}
CompressionMethod::Unsupported(..) => {
return Err(ZipError::UnsupportedArchive("Unsupported compression"))

@ -5,8 +5,8 @@
%global crate zip
Name: rust-%{crate}
Version: 0.5.9
Release: 2%{?dist}
Version: 0.5.11
Release: 1%{?dist}
Summary: Library to support the reading and writing of zip files
# Upstream license specification: MIT
@ -14,8 +14,10 @@ License: MIT
URL: https://crates.io/crates/zip
Source: %{crates_source}
# Initial patched metadata
# * relax flate2 dependency to allow > 1.0.14
# * relax flate2 dependency to allow > 1.0.14 (do not care about MSRV in Fedora)
# * bump bzip2 from 0.3 to 0.4: https://github.com/zip-rs/zip/pull/202
Patch0: zip-fix-metadata.diff
Patch1: port-to-bzip2-0.4.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -146,6 +148,10 @@ which use "time" feature of "%{crate}" crate.
%endif
%changelog
* Mon Mar 01 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.11-1
- Update to version 0.5.11.
- Bump to bzip2 0.4.
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

@ -1 +1 @@
SHA512 (zip-0.5.9.crate) = d22c079dabc946becc9d4c05fa65b95ae62422e0abcb95ee036415b58fb212c8d0996d71a30a62a32f0d710a8ba04c1d8b856e38ef6d088c6ce7b7f5eb3b563d
SHA512 (zip-0.5.11.crate) = 92e3d05af2f1020383c8573aed6a7d2964604bad74d2d92e5102b9c34185242b44c005e0a081e2517cbbbe4cdc2e78ae86881fda07557b604ece98fb94e383f2

@ -1,6 +1,14 @@
--- zip-0.5.9/Cargo.toml 2020-12-06T23:39:50+00:00
+++ zip-0.5.9/Cargo.toml 2020-12-07T13:35:45.295316+00:00
@@ -35,7 +35,7 @@
--- zip-0.5.11/Cargo.toml 2021-03-01T12:07:05+00:00
+++ zip-0.5.11/Cargo.toml 2021-03-01T16:50:52.208395+00:00
@@ -27,14 +27,14 @@
version = "1.3"
[dependencies.bzip2]
-version = "0.3"
+version = "0.4"
optional = true
[dependencies.crc32fast]
version = "1.0"
[dependencies.flate2]

Loading…
Cancel
Save