You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-zeroize/rust-zeroize.spec

146 lines
3.7 KiB

# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate zeroize
Name: rust-zeroize
Version: 1.7.0
Release: %autorelease
Summary: Securely clear secrets from memory
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/zeroize
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Securely clear secrets from memory with a simple trait built on stable
Rust primitives which guarantee memory is zeroed using an operation will
not be 'optimized away' by the compiler. Uses a portable pure Rust
implementation that works everywhere, even WASM!.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+aarch64-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+aarch64-devel %{_description}
This package contains library source intended for building other packages which
use the "aarch64" feature of the "%{crate}" crate.
%files -n %{name}+aarch64-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+derive-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+derive-devel %{_description}
This package contains library source intended for building other packages which
use the "derive" feature of the "%{crate}" crate.
%files -n %{name}+derive-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zeroize_derive-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zeroize_derive-devel %{_description}
This package contains library source intended for building other packages which
use the "zeroize_derive" feature of the "%{crate}" crate.
%files -n %{name}+zeroize_derive-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog