You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-zerofrom-derive/rust-zerofrom-derive.spec

75 lines
1.7 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate zerofrom-derive
Name: rust-zerofrom-derive
Version: 0.1.5
Release: %autorelease
Summary: Custom derive for the zerofrom crate
License: Unicode-3.0
URL: https://crates.io/crates/zerofrom-derive
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * Patch out the "zf_derive" example to avoid a circular dependency on the
# zerofrom crate.
Patch: zerofrom-derive-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Custom derive for the zerofrom crate.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
# Avoid a circular dependency on the zerofrom crate
rm examples/zf_derive.rs
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog