commit
264527893c
@ -0,0 +1 @@
|
||||
SOURCES/zerofrom-derive-0.1.5.crate
|
@ -0,0 +1 @@
|
||||
03efcd4c9145920ddd788cd94c7b222d282128c9 SOURCES/zerofrom-derive-0.1.5.crate
|
@ -0,0 +1,3 @@
|
||||
# rust-zerofrom-derive
|
||||
|
||||
The rust-zerofrom-derive package
|
@ -0,0 +1,2 @@
|
||||
# Feature metapackages are not supposed to have documentation!
|
||||
addFilter(r"\+[-_\w]+-devel.noarch: W: no-documentation")
|
@ -0,0 +1,13 @@
|
||||
[package]
|
||||
cargo-toml-patch-comments = [
|
||||
"""\
|
||||
Patch out the \"zf_derive\" example to avoid a circular dependency on the \
|
||||
zerofrom crate.\
|
||||
""",
|
||||
]
|
||||
|
||||
[scripts.prep]
|
||||
pre = [
|
||||
"# Avoid a circular dependency on the zerofrom crate",
|
||||
"rm examples/zf_derive.rs",
|
||||
]
|
@ -0,0 +1,13 @@
|
||||
--- zerofrom-derive-0.1.5/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ zerofrom-derive-0.1.5/Cargo.toml 2024-11-23T04:34:46.819876+00:00
|
||||
@@ -44,10 +44,6 @@
|
||||
path = "src/lib.rs"
|
||||
proc-macro = true
|
||||
|
||||
-[[example]]
|
||||
-name = "zf_derive"
|
||||
-path = "examples/zf_derive.rs"
|
||||
-
|
||||
[dependencies.proc-macro2]
|
||||
version = "1.0.61"
|
||||
|
@ -0,0 +1,93 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.7.3)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate zerofrom-derive
|
||||
|
||||
Name: rust-zerofrom-derive
|
||||
Version: 0.1.5
|
||||
Release: %autorelease
|
||||
Summary: Custom derive for the zerofrom crate
|
||||
|
||||
License: Unicode-3.0
|
||||
URL: https://crates.io/crates/zerofrom-derive
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * Patch out the "zf_derive" example to avoid a circular dependency on the
|
||||
# zerofrom crate.
|
||||
Patch: zerofrom-derive-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Custom derive for the zerofrom crate.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
# Avoid a circular dependency on the zerofrom crate
|
||||
rm examples/zf_derive.rs
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.1.5-1
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
## START: Generated by rpmautospec
|
||||
* Sat Nov 23 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.1.5-1
|
||||
- Update to 0.1.5 (close RHBZ#2328450)
|
||||
|
||||
* Tue Sep 10 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.1.4-1
|
||||
- Initial package (close RHBZ#2310825)
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in new issue