import rust-yoke-derive-0.7.5-1.el10

i10ce changed/i10ce/rust-yoke-derive-0.7.5-1.el10
MSVSphere Packaging Team 2 months ago
commit 77c63d61b0
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/yoke-derive-0.7.5.crate

@ -0,0 +1 @@
5885d10a3cdaa6ac22fefb828f79a6c1bc239de1 SOURCES/yoke-derive-0.7.5.crate

@ -0,0 +1,3 @@
# rust-yoke-derive
The rust-yoke-derive package

@ -0,0 +1,2 @@
# Feature metapackages are not supposed to have documentation!
addFilter(r"\+[-_\w]+-devel.noarch: W: no-documentation")

@ -0,0 +1,10 @@
[package]
cargo-toml-patch-comments = [
"Patch out the examples to avoid a circular dependency on the yoke crate.",
]
[scripts.prep]
pre = [
"# Avoid a circular dependency on the yoke crate",
"rm -rv examples/",
]

@ -0,0 +1,13 @@
--- yoke-derive-0.7.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ yoke-derive-0.7.5/Cargo.toml 2024-11-23T05:11:14.372641+00:00
@@ -45,10 +45,6 @@
path = "src/lib.rs"
proc-macro = true
-[[example]]
-name = "yoke_derive"
-path = "examples/yoke_derive.rs"
-
[dependencies.proc-macro2]
version = "1.0.61"

@ -0,0 +1,92 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate yoke-derive
Name: rust-yoke-derive
Version: 0.7.5
Release: %autorelease
Summary: Custom derive for the yoke crate
License: Unicode-3.0
URL: https://crates.io/crates/yoke-derive
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * Patch out the examples to avoid a circular dependency on the yoke crate.
Patch: yoke-derive-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Custom derive for the yoke crate.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
# Avoid a circular dependency on the yoke crate
rm -rv examples/
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.7.5-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Sat Nov 23 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.7.5-1
- Update to 0.7.5 (close RHBZ#2328448)
* Fri Sep 13 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.7.4-1
- Initial package (close RHBZ#2311958)
## END: Generated by rpmautospec
Loading…
Cancel
Save