Initial import (#2232626)
parent
9e075253f7
commit
ba17342e64
@ -0,0 +1 @@
|
||||
/yansi-term-0.1.2.crate
|
@ -0,0 +1,94 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate yansi-term
|
||||
|
||||
Name: rust-yansi-term
|
||||
Version: 0.1.2
|
||||
Release: %autorelease
|
||||
Summary: Library for ANSI terminal colours and styles (bold, underline)
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/yansi-term
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: yansi-term-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Library for ANSI terminal colours and styles (bold, underline).}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENCE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+derive_serde_style-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+derive_serde_style-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "derive_serde_style" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+derive_serde_style-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (yansi-term-0.1.2.crate) = ba720e36487871427aaa7139e8aeaf5b2b3f2d1df4798d7e238e323dc3d3220f12202e223f74339201be3466848c372dc1712e1842e5cd6bd51c3dedf76c9ff6
|
@ -0,0 +1,12 @@
|
||||
--- yansi-term-0.1.2/Cargo.toml 2020-05-31T12:48:56+00:00
|
||||
+++ yansi-term-0.1.2/Cargo.toml 2023-08-17T15:27:40.846610+00:00
|
||||
@@ -36,9 +36,6 @@
|
||||
|
||||
[features]
|
||||
derive_serde_style = ["serde"]
|
||||
-[target."cfg(target_os=\"windows\")".dependencies.winapi]
|
||||
-version = "0.3.4"
|
||||
-features = ["consoleapi", "errhandlingapi", "fileapi", "handleapi", "processenv"]
|
||||
[badges.maintenance]
|
||||
status = "actively-developed"
|
||||
|
Loading…
Reference in new issue