Disable tests and drop support for tokio v0.1

epel10 imports/epel10/rust-xz2-0.1.7-8.el10
Fabio Valentini 5 months ago
parent 13cf837475
commit 6e0f9b40b8
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,5 +1,6 @@
# Generated by rust2rpm 24
%bcond_without check
# Generated by rust2rpm 26
# * outdated dev-dependencies: tokio v0.1
%bcond_with check
%global debug_package %{nil}
%global crate xz2
@ -14,10 +15,11 @@ License: MIT OR Apache-2.0
URL: https://crates.io/crates/xz2
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused support for tokio v0.1
# * drop feature for statically linking liblzma
Patch: xz2-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Rust bindings to liblzma providing Read/Write streams as well as low-
@ -52,44 +54,8 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-devel %{_description}
This package contains library source intended for building other packages which
use the "futures" feature of the "%{crate}" crate.
%files -n %{name}+futures-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio" feature of the "%{crate}" crate.
%files -n %{name}+tokio-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-io-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-io-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio-io" feature of the "%{crate}" crate.
%files -n %{name}+tokio-io-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
@ -103,8 +69,7 @@ use the "tokio-io" feature of the "%{crate}" crate.
%if %{with check}
%check
# * skip a test that relies on files which are not included in published crates
%cargo_test -- -- --skip standard_files
%cargo_test
%endif
%changelog

@ -1,2 +0,0 @@
[DEFAULT]
summary = Rust bindings to liblzma

@ -0,0 +1,11 @@
[package]
summary = "Rust bindings to liblzma"
cargo-toml-patch-comments = [
"drop unused support for tokio v0.1",
"drop feature for statically linking liblzma",
]
[tests]
run = ["none"]
comments = ["outdated dev-dependencies: tokio v0.1"]

@ -1,10 +1,29 @@
--- xz2-0.1.7/Cargo.toml 1970-01-01T00:00:01+00:00
+++ xz2-0.1.7/Cargo.toml 2023-08-07T18:47:19.875968+00:00
@@ -60,7 +60,6 @@
+++ xz2-0.1.7/Cargo.toml 2024-09-21T23:12:17.487893+00:00
@@ -39,16 +39,8 @@
"futures",
]
-[dependencies.futures]
-version = "0.1.26"
-optional = true
-
[dependencies.lzma-sys]
version = "0.1.18"
-
-[dependencies.tokio-io]
-version = "0.1.12"
-optional = true
[dev-dependencies.quickcheck]
version = "1.0.1"
@@ -59,9 +51,3 @@
[dev-dependencies.tokio-core]
version = "0.1.17"
[features]
-[features]
-static = ["lzma-sys/static"]
tokio = [
"tokio-io",
"futures",
-tokio = [
- "tokio-io",
- "futures",
-]

Loading…
Cancel
Save