parent
13cf837475
commit
6e0f9b40b8
@ -1,2 +0,0 @@
|
||||
[DEFAULT]
|
||||
summary = Rust bindings to liblzma
|
@ -0,0 +1,11 @@
|
||||
[package]
|
||||
summary = "Rust bindings to liblzma"
|
||||
cargo-toml-patch-comments = [
|
||||
"drop unused support for tokio v0.1",
|
||||
"drop feature for statically linking liblzma",
|
||||
]
|
||||
|
||||
[tests]
|
||||
run = ["none"]
|
||||
comments = ["outdated dev-dependencies: tokio v0.1"]
|
||||
|
@ -1,10 +1,29 @@
|
||||
--- xz2-0.1.7/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ xz2-0.1.7/Cargo.toml 2023-08-07T18:47:19.875968+00:00
|
||||
@@ -60,7 +60,6 @@
|
||||
+++ xz2-0.1.7/Cargo.toml 2024-09-21T23:12:17.487893+00:00
|
||||
@@ -39,16 +39,8 @@
|
||||
"futures",
|
||||
]
|
||||
|
||||
-[dependencies.futures]
|
||||
-version = "0.1.26"
|
||||
-optional = true
|
||||
-
|
||||
[dependencies.lzma-sys]
|
||||
version = "0.1.18"
|
||||
-
|
||||
-[dependencies.tokio-io]
|
||||
-version = "0.1.12"
|
||||
-optional = true
|
||||
|
||||
[dev-dependencies.quickcheck]
|
||||
version = "1.0.1"
|
||||
@@ -59,9 +51,3 @@
|
||||
[dev-dependencies.tokio-core]
|
||||
version = "0.1.17"
|
||||
|
||||
[features]
|
||||
-[features]
|
||||
-static = ["lzma-sys/static"]
|
||||
tokio = [
|
||||
"tokio-io",
|
||||
"futures",
|
||||
-tokio = [
|
||||
- "tokio-io",
|
||||
- "futures",
|
||||
-]
|
||||
|
Loading…
Reference in new issue