Drop unused "garbage" feature with missing dependencies

epel9 imports/e9/rust-wyz-0.5.1-2.el9
Fabio Valentini 2 years ago
parent bbb911d4f5
commit e53a48d0fd
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -12,6 +12,9 @@ Summary: Myrrlyns utility collection
License: MIT
URL: https://crates.io/crates/wyz
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused "garbage" feature with missing dependencies
Patch: wyz-fix-metadata.diff
BuildRequires: rust-packaging >= 21
@ -58,30 +61,6 @@ use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+garbage-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+garbage-devel %{_description}
This package contains library source intended for building other packages which
use the "garbage" feature of the "%{crate}" crate.
%files -n %{name}+garbage-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+once_cell-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+once_cell-devel %{_description}
This package contains library source intended for building other packages which
use the "once_cell" feature of the "%{crate}" crate.
%files -n %{name}+once_cell-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
@ -94,18 +73,6 @@ use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+typemap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+typemap-devel %{_description}
This package contains library source intended for building other packages which
use the "typemap" feature of the "%{crate}" crate.
%files -n %{name}+typemap-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

@ -0,0 +1,25 @@
--- wyz-0.5.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ wyz-0.5.1/Cargo.toml 2023-03-02T15:30:04.570364+00:00
@@ -29,22 +29,10 @@
license = "MIT"
repository = "https://github.com/myrrlyn/wyz"
-[dependencies.once_cell]
-version = "1"
-optional = true
-
[dependencies.tap]
version = "1"
-
-[dependencies.typemap]
-version = "0.3"
-optional = true
[features]
alloc = []
default = ["std"]
-garbage = [
- "once_cell",
- "typemap",
-]
std = ["alloc"]
Loading…
Cancel
Save