You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-writeable/rust-writeable.spec

98 lines
2.3 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate writeable
Name: rust-writeable
Version: 0.5.5
Release: %autorelease
Summary: More efficient alternative to fmt::Display
License: Unicode-3.0
URL: https://crates.io/crates/writeable
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * Drop benchmark-only criterion dependency
Patch: writeable-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A more efficient alternative to fmt::Display.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bench-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bench-devel %{_description}
This package contains library source intended for building other packages which
use the "bench" feature of the "%{crate}" crate.
%files -n %{name}+bench-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+either-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+either-devel %{_description}
This package contains library source intended for building other packages which
use the "either" feature of the "%{crate}" crate.
%files -n %{name}+either-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
# Avoid a dependency on the internal icu_benchmark_macros crate
rm -rv examples/
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog