You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-wild/rust-wild.spec

83 lines
1.9 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate wild
Name: rust-wild
Version: 2.2.0
Release: %autorelease
Summary: Glob (wildcard) expanded command-line arguments
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/wild
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: wild-fix-metadata-auto.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Glob (wildcard) expanded command-line arguments on Windows.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+glob-quoted-on-windows-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+glob-quoted-on-windows-devel %{_description}
This package contains library source intended for building other packages which
use the "glob-quoted-on-windows" feature of the "%{crate}" crate.
%files -n %{name}+glob-quoted-on-windows-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog