Update glob to 0.3

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 4c777b2a9d
commit ea0288f98c
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -0,0 +1,26 @@
From 7a4f0e5e89ca1a5082c4a2c2f77ec7a91ae44343 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Tue, 7 May 2019 12:14:35 +0000
Subject: [PATCH] chore: Update glob to 0.3
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/argsiter.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/argsiter.rs b/src/argsiter.rs
index 760ac76..bbe17ed 100644
--- a/src/argsiter.rs
+++ b/src/argsiter.rs
@@ -44,7 +44,7 @@ impl Iterator for ArgsOs {
Some(ref mut args) => match args.next() {
// lossy: https://github.com/rust-lang-nursery/glob/issues/23
Some(arg) => if arg.contains_glob {
- match glob::glob_with(&arg.pattern.to_string_lossy(), &glob_options) {
+ match glob::glob_with(&arg.pattern.to_string_lossy(), glob_options) {
Ok(mut glob_iter) => {
let first_glob = first_non_error(&mut glob_iter);
self.current_arg_globs = Some(glob_iter);
--
2.21.0

@ -1,4 +1,4 @@
# Generated by rust2rpm
# Generated by rust2rpm-9-1.fc31
%bcond_with check
%global debug_package %{nil}
@ -6,22 +6,26 @@
Name: rust-%{crate}
Version: 2.0.1
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Glob (wildcard) expanded command-line arguments
# Upstream license specification: MIT
# https://gitlab.com/kornelski/wild/issues/2
License: MIT
URL: https://crates.io/crates/wild
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
Source: %{crates_source}
# Initial patched metadata
# * No windows
# * Update glob to 0.3, https://gitlab.com/kornelski/wild/merge_requests/2
Patch0: wild-fix-metadata.diff
# Make it work with new glob
Patch1: 0001-chore-Update-glob-to-0.3.patch
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
%if %{with check}
BuildRequires: (crate(glob/default) >= 0.2.11 with crate(glob/default) < 0.3.0)
BuildRequires: (crate(glob/default) >= 0.3.0 with crate(glob/default) < 0.4.0)
%endif
%global _description \
@ -55,7 +59,7 @@ which use "default" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
@ -70,6 +74,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Tue May 07 14:13:33 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.1-3
- Update glob to 0.3
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1,11 +1,13 @@
--- wild-2.0.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ wild-2.0.1/Cargo.toml 2018-11-04T17:23:27.957851+01:00
@@ -24,8 +24,6 @@
--- wild-2.0.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ wild-2.0.1/Cargo.toml 2019-05-07T12:13:33.827001+00:00
@@ -23,9 +23,7 @@
license = "MIT"
repository = "https://gitlab.com/kornelski/wild"
[dev-dependencies.glob]
version = "0.2.11"
-version = "0.2.11"
-[target."cfg(windows)".dependencies.glob]
-version = "0.2.11"
+version = "0.3"
[badges.appveyor]
repository = "pornel/wild"

Loading…
Cancel
Save