Update to version 1.1.0; Fixes RHBZ#2273816

epel10
Fabio Valentini 9 months ago
parent ebf4af503e
commit 222549e438
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/widestring-1.0.2.crate
/widestring-1.1.0.crate

@ -1,34 +0,0 @@
From dc351ced4049f1349d9eb183bbc24e33d0cceb40 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Sun, 1 Oct 2023 15:57:10 +0200
Subject: [PATCH] drop doctests that can only be run on Windows
---
src/lib.rs | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/lib.rs b/src/lib.rs
index e211e24..3d41bc8 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -122,7 +122,7 @@
//! returns a string length for us and we don't need to pass error messages into other FFI
//! functions so we don't need to worry about nul values.
//!
-//! ```rust
+//! ```rust,ignore
//! # #[cfg(any(not(windows), not(feature = "alloc")))]
//! # fn main() {}
//! # extern crate winapi;
@@ -166,7 +166,7 @@
//!
//! The following example is the functionally the same, only using [`U16CString`] instead.
//!
-//! ```rust
+//! ```rust,ignore
//! # #[cfg(any(not(windows), not(feature = "alloc")))]
//! # fn main() {}
//! # extern crate winapi;
--
2.41.0

@ -1,24 +1,20 @@
# Generated by rust2rpm 24
%bcond_without check
# Generated by rust2rpm 26
# * tests can only be run on Windows
%bcond_with check
%global debug_package %{nil}
%global crate widestring
Name: rust-widestring
Version: 1.0.2
Version: 1.1.0
Release: %autorelease
Summary: Converting to and from wide strings (UTF-16 and UTF-32)
License: MIT OR Apache-2.0
URL: https://crates.io/crates/widestring
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop Windows-specific dev-dependency
Patch: widestring-fix-metadata.diff
# * drop tests that can only be run on windows
Patch: 0001-drop-doctests-that-can-only-be-run-on-Windows.patch
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A wide string Rust library for converting to and from wide strings, such
@ -81,7 +77,7 @@ use the "std" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires

@ -0,0 +1,10 @@
[package]
summary = "Converting to and from wide strings (UTF-16 and UTF-32)"
[features]
hide = ["debugger_visualizer"]
[tests]
run = ["none"]
comments = ["tests can only be run on Windows"]

@ -1 +1 @@
SHA512 (widestring-1.0.2.crate) = cbebac37d87808e791d7839ad69e0b86af49b0e8a354a22e11797915c719937ed5b0cb638e5afc9d710cd1e073eaa9f7db76cd3ca1ec35a71b565f0b8f55407b
SHA512 (widestring-1.1.0.crate) = a4feb959e19d5238e89b0973f040b26849f896e7e9fd567d0e74fbb4972958a4dd76e74de5ea8d407b74cff28f20f9c80446488da6abdbee38aa87a94d683435

@ -1,13 +0,0 @@
--- widestring-1.0.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ widestring-1.0.2/Cargo.toml 2023-10-01T13:57:33.483751+00:00
@@ -43,10 +43,6 @@
"docsrs",
]
-[dev-dependencies.winapi]
-version = "0.3"
-features = ["winbase"]
-
[features]
alloc = []
default = ["std"]
Loading…
Cancel
Save