Initial import (which 4 compat package)

epel10
Fabio Valentini 1 year ago
parent 2be844a238
commit 7b66beb2ae
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/which-4.4.2.crate

@ -1,3 +0,0 @@
# rust-which4
The rust-which4 package

@ -0,0 +1,84 @@
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate which
Name: rust-which4
Version: 4.4.2
Release: %autorelease
Summary: Rust equivalent of Unix command "which"
License: MIT
URL: https://crates.io/crates/which
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: which-fix-metadata-auto.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A Rust equivalent of Unix command "which". Locate installed executable
in cross platforms.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE.txt
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-devel %{_description}
This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (which-4.4.2.crate) = 2d12aa1d4c2dbc140e39c8f15bd4ee1eeb8e8de71bcdf579479ef4be860fb0839eaf4cdb818addba242d50420f6e08acaf2bfc979a889e092c83644819246fd5

@ -0,0 +1,8 @@
--- which-4.4.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ which-4.4.2/Cargo.toml 2024-01-19T19:30:28.339537+00:00
@@ -55,5 +55,3 @@
[target."cfg(any(windows, unix, target_os = \"redox\"))".dependencies.home]
version = "0.5.5"
-[target."cfg(windows)".dependencies.once_cell]
-version = "1"
Loading…
Cancel
Save