commit
61958a0397
Binary file not shown.
@ -0,0 +1,12 @@
|
||||
--- weezl-0.1.7/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ weezl-0.1.7/Cargo.toml 2022-07-18T08:34:15.942522+00:00
|
||||
@@ -72,9 +72,6 @@
|
||||
optional = true
|
||||
default-features = false
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3.1"
|
||||
-
|
||||
[dev-dependencies.tokio]
|
||||
version = "1"
|
||||
features = [
|
@ -0,0 +1,185 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.0)
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 2;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 21
|
||||
%bcond_without check
|
||||
|
||||
%global crate weezl
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.7
|
||||
Release: %autorelease
|
||||
Summary: Fast LZW compression and decompression
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/weezl
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||
Patch0: weezl-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Fast LZW compression and decompression.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package -n %{crate}
|
||||
Summary: %{summary}
|
||||
|
||||
%description -n %{crate} %{_description}
|
||||
|
||||
%files -n %{crate}
|
||||
%license LICENSE-APACHE
|
||||
%license LICENSE-MIT
|
||||
%doc Changes.md
|
||||
%doc README.md
|
||||
%{_bindir}/lzw
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/Changes.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "alloc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+alloc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+async-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+async-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "async" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+async-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
# * files needed for encode/decode tests are not included in published crates
|
||||
%cargo_test -- --doc
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.1.7-2
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.1.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Mon Jul 18 2022 Fabio Valentini <decathorpe@gmail.com> 0.1.7-1
|
||||
- Update to version 0.1.7; Fixes RHBZ#2077517
|
||||
|
||||
* Tue Feb 15 2022 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.1.5-5
|
||||
- Rebuild with package notes
|
||||
|
||||
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.5-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Sat Aug 07 2021 Fabio Valentini <decathorpe@gmail.com> - 0.1.5-3
|
||||
- Rebuild with crossbeam-deque 0.8.1 / 0.7.4 for CVE-2021-32810
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Wed Apr 21 2021 Fabio Valentini <decathorpe@gmail.com> - 0.1.5-1
|
||||
- Update to version 0.1.5.
|
||||
- Fixes RHBZ#1950696
|
||||
|
||||
* Thu Mar 04 2021 Fabio Valentini <decathorpe@gmail.com> - 0.1.4-1
|
||||
- Update to version 0.1.4.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Nov 11 2020 Fabio Valentini <decathorpe@gmail.com> - 0.1.3-1
|
||||
- Update to version 0.1.3.
|
||||
- Fixes RHBZ#1896510
|
||||
|
||||
* Fri Oct 23 2020 Fabio Valentini <decathorpe@gmail.com> - 0.1.2-1
|
||||
- Update to version 0.1.2.
|
||||
|
||||
* Thu Oct 01 2020 Fabio Valentini <decathorpe@gmail.com> - 0.1.0-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue