Adapt to new packaging

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent f57d862f9e
commit f5a5bffe5d
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,5 +1,5 @@
# Generated by rust2rpm
# Tests are run in infrastructure
# * Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}
@ -7,7 +7,7 @@
Name: rust-%{crate}
Version: 2.2.5
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Recursively walk a directory
# Upstream license specification: Unlicense/MIT
@ -16,34 +16,51 @@ URL: https://crates.io/crates/walkdir
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No windows
# * Exclude CI files, https://github.com/BurntSushi/walkdir/pull/114
Patch0: walkdir-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(same-file) >= 1.0.1 with crate(same-file) < 2.0.0)
BuildRequires: (crate(same-file/default) >= 1.0.1 with crate(same-file/default) < 2.0.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(docopt) >= 1.0.1 with crate(docopt) < 2.0.0)
BuildRequires: (crate(docopt/default) >= 1.0.1 with crate(docopt/default) < 2.0.0)
BuildRequires: (crate(quickcheck) >= 0.7.0 with crate(quickcheck) < 0.8.0)
BuildRequires: (crate(rand) >= 0.5.0 with crate(rand) < 0.6.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: (crate(serde_derive) >= 1.0.0 with crate(serde_derive) < 2.0.0)
BuildRequires: (crate(rand/default) >= 0.5.0 with crate(rand/default) < 0.6.0)
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.0 with crate(serde_derive/default) < 2.0.0)
%endif
%description
%{summary}.
%global _description \
Recursively walk a directory.
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
Recursively walk a directory.
%description devel %{_description}
This package contains library source intended for building other packages
which use %{crate} from crates.io.
which use "%{crate}" crate.
%files devel
%license UNLICENSE LICENSE-MIT COPYING
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
@ -60,13 +77,10 @@ which use %{crate} from crates.io.
%cargo_test
%endif
%files devel
%license UNLICENSE LICENSE-MIT COPYING
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{Makefile,appveyor.yml,compare,ctags.rust,session.vim}
%changelog
* Sat Oct 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.2.5-2
- Adapt to new packaging
* Fri Sep 07 2018 Josh Stone <jistone@redhat.com> - 2.2.5-1
- Update to 2.2.5

@ -1,6 +1,14 @@
--- walkdir-2.2.5/Cargo.toml 1969-12-31T16:00:00-08:00
+++ walkdir-2.2.5/Cargo.toml 2018-09-07T13:47:15.764608-07:00
@@ -39,12 +39,6 @@
--- walkdir-2.2.5/Cargo.toml 1970-01-01T01:00:00+01:00
+++ walkdir-2.2.5/Cargo.toml 2018-10-27T23:35:24.891683+02:00
@@ -22,6 +22,7 @@
categories = ["filesystem"]
license = "Unlicense/MIT"
repository = "https://github.com/BurntSushi/walkdir"
+exclude = ["/ci/*", "/.travis.yml", "/Makefile", "/appveyor.yml", "/ctags.rust", "/session.vim"]
[dependencies.same-file]
version = "1.0.1"
[dev-dependencies.docopt]
@@ -39,12 +40,6 @@
[dev-dependencies.serde_derive]
version = "1"

Loading…
Cancel
Save