Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 10ca84fb33
commit da38aa05a2
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,37 +1,42 @@
# Generated by rust2rpm
# * Tests are run in infrastructure
%bcond_with check
# Generated by rust2rpm 9
%bcond_without check
%global debug_package %{nil}
%global crate walkdir
Name: rust-%{crate}
Version: 2.2.7
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Recursively walk a directory
# Upstream license specification: Unlicense/MIT
License: Unlicense or MIT
URL: https://crates.io/crates/walkdir
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
Source: %{crates_source}
# Initial patched metadata
# * No windows
# * Update quickcheck to 0.8, https://github.com/BurntSushi/walkdir/pull/122
Patch0: walkdir-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%if ! %{__cargo_skip_build}
BuildRequires: (crate(same-file/default) >= 1.0.1 with crate(same-file/default) < 2.0.0)
%if %{with check}
BuildRequires: (crate(docopt/default) >= 1.0.1 with crate(docopt/default) < 2.0.0)
BuildRequires: (crate(quickcheck) >= 0.7.0 with crate(quickcheck) < 0.8.0)
BuildRequires: (crate(quickcheck) >= 0.8.0 with crate(quickcheck) < 0.9.0)
BuildRequires: (crate(rand/default) >= 0.5.0 with crate(rand/default) < 0.6.0)
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.0 with crate(serde_derive/default) < 2.0.0)
%endif
%endif
%global _description \
Recursively walk a directory.
%global _description %{expand:
Recursively walk a directory.}
%description %{_description}
@ -62,7 +67,7 @@ which use "default" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
@ -77,6 +82,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Sun Jun 09 09:57:45 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.2.7-3
- Regenerate
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1,5 +1,14 @@
--- walkdir-2.2.7/Cargo.toml 1969-12-31T16:00:00-08:00
+++ walkdir-2.2.7/Cargo.toml 2018-11-12T21:27:05.522011-08:00
--- walkdir-2.2.7/Cargo.toml 1970-01-01T00:00:00+00:00
+++ walkdir-2.2.7/Cargo.toml 2019-06-09T08:02:10.540613+00:00
@@ -29,7 +29,7 @@
version = "1.0.1"
[dev-dependencies.quickcheck]
-version = "0.7"
+version = "0.8"
default-features = false
[dev-dependencies.rand]
@@ -40,12 +40,6 @@
[dev-dependencies.serde_derive]

Loading…
Cancel
Save