Bump rand to 0.4

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 1dabe67de2
commit 6517be3a4a

@ -6,7 +6,7 @@
Name: rust-%{crate}
Version: 2.0.1
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Recursively walk a directory
License: Unlicense or MIT
@ -14,6 +14,7 @@ URL: https://crates.io/crates/walkdir
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump quickcheck to 0.5, https://github.com/utkarshkukreti/diff.rs/commit/77c5dd7c787375e15c42f0117ce19f53b9db03fa
# * Bump rand to 0.4, https://github.com/BurntSushi/walkdir/pull/86
Patch0: walkdir-2.0.1-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -25,7 +26,7 @@ BuildRequires: (crate(same-file) >= 1.0.0 with crate(same-file) < 2.0.0)
# [dev-dependencies]
BuildRequires: (crate(docopt) >= 0.8.0 with crate(docopt) < 0.9.0)
BuildRequires: (crate(quickcheck) >= 0.5.0 with crate(quickcheck) < 0.6.0)
BuildRequires: (crate(rand) >= 0.3.0 with crate(rand) < 0.4.0)
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: (crate(serde_derive) >= 1.0.0 with crate(serde_derive) < 2.0.0)
%endif
@ -65,6 +66,9 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/{Makefile,appveyor.yml,compare,ctags.rust,session.vim}
%changelog
* Sun Dec 31 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.1-3
- Bump rand to 0.4
* Sat Dec 02 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.1-2
- Bump quickcheck to 0.5

@ -1,11 +1,12 @@
--- walkdir-2.0.1/Cargo.toml 2017-10-22T00:55:02+02:00
+++ walkdir-2.0.1/Cargo.toml 2017-12-02T17:06:34.273386+01:00
+++ walkdir-2.0.1/Cargo.toml 2017-12-31T18:50:50.496821+01:00
@@ -21,7 +21,7 @@
[dev-dependencies]
docopt = "0.8"
-quickcheck = { version = "0.4", default-features = false }
-rand = "0.3"
+quickcheck = { version = "0.5", default-features = false }
rand = "0.3"
+rand = "0.4"
serde = "1"
serde_derive = "1"

Loading…
Cancel
Save