You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-waker-fn/rust-waker-fn.spec

95 lines
2.2 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate waker-fn
Name: rust-waker-fn
Version: 1.2.0
Release: %autorelease
Summary: Convert closures into wakers
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/waker-fn
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Convert closures into wakers.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+portable-atomic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+portable-atomic-devel %{_description}
This package contains library source intended for building other packages which
use the "portable-atomic" feature of the "%{crate}" crate.
%files -n %{name}+portable-atomic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+portable-atomic-util-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+portable-atomic-util-devel %{_description}
This package contains library source intended for building other packages which
use the "portable-atomic-util" feature of the "%{crate}" crate.
%files -n %{name}+portable-atomic-util-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog