You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-wait-timeout/rust-wait-timeout.spec

76 lines
1.8 KiB

# Generated by rust2rpm 24
# * running tests requires building unwanted executables
%bcond_with check
%global debug_package %{nil}
%global crate wait-timeout
Name: rust-wait-timeout
Version: 0.2.0
Release: %autorelease
Summary: Crate to wait on a child process with a timeout
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/wait-timeout
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop executables that are only useful for tests
Patch: wait-timeout-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
A crate to wait on a child process with a timeout specified across Unix
and Windows platforms.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog