Update to 0.8.0

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 4 years ago
parent c8247797fb
commit b43ba11ba4
No known key found for this signature in database
GPG Key ID: 115D5AB89C5C1E1E

1
.gitignore vendored

@ -1 +1,2 @@
/vte-0.3.3.crate
/vte-0.8.0.crate

@ -1,21 +1,18 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 15
%bcond_without check
%global debug_package %{nil}
%global crate vte
Name: rust-%{crate}
Version: 0.3.3
Release: 5%{?dist}
Version: 0.8.0
Release: 1%{?dist}
Summary: Parser for implementing terminal emulators
# Upstream license specification: Apache-2.0 OR MIT
License: ASL 2.0 or MIT
URL: https://crates.io/crates/vte
Source: %{crates_source}
# Initial patched metadata
# * Do not ship some random binaries
Patch0: vte-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -25,14 +22,7 @@ BuildArch: noarch
BuildRequires: rust-packaging
%global _description %{expand:
Parser for implementing virtual terminal emulators in Rust.
The parser is implemented according to Paul Williams' ANSI parser state
machine. The state machine doesn't assign meaning to the parsed data and is
thus not itself sufficient for writing a terminal emulator. Instead, it is
expected that an implementation of the Perform trait which does something
useful with the parsed data. The Parser handles the book keeping, and the
Perform gets to simply handle actions.}
Parser for implementing terminal emulators.}
%description %{_description}
@ -46,9 +36,9 @@ This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%doc CHANGELOG.md README.md
%license LICENSE-APACHE LICENSE-MIT
%{cargo_registry}/%{crate}-%{version}/
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -60,12 +50,46 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+arrayvec-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arrayvec-devel %{_description}
This package contains library source intended for building other packages
which use "arrayvec" feature of "%{crate}" crate.
%files -n %{name}+arrayvec-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages
which use "nightly" feature of "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+no_std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+no_std-devel %{_description}
This package contains library source intended for building other packages
which use "no_std" feature of "%{crate}" crate.
%files -n %{name}+no_std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# Fix broken example
mv foos benches
%cargo_prep
%generate_buildrequires
@ -83,6 +107,9 @@ mv foos benches
%endif
%changelog
* Thu Aug 27 16:54:58 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.8.0-1
- Update to 0.8.0
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

@ -1 +1 @@
SHA512 (vte-0.3.3.crate) = 5e00e8409ef21edb5aa6fbe482785fd5969dd17a6695f82328c4ae12ea8622712dc3473f33832fdfe0cc2395411431fd47842e86e35022149d5e958c4e5f8fe9
SHA512 (vte-0.8.0.crate) = c4545c8e12bdb78674434eb8414dac9d2885c2547f302d19533eeb77dc2dc8d97f077ace4905f8f105269e68b808bd01a1a825ddb86fe5947c8a4acf18ea4ee7

@ -1,9 +0,0 @@
--- vte-0.3.3/Cargo.toml 1970-01-01T00:00:00+00:00
+++ vte-0.3.3/Cargo.toml 2019-04-24T06:27:48.320365+00:00
@@ -20,5 +20,6 @@
keywords = ["ansi", "vte", "parser", "terminal"]
license = "Apache-2.0 OR MIT"
repository = "https://github.com/jwilm/vte"
+exclude = ["/vim10m_*"]
[dependencies.utf8parse]
version = "0.1"
Loading…
Cancel
Save