commit
21a9566376
@ -0,0 +1,32 @@
|
||||
From 4f9abc6a9c2f4918a445f8217a07849eb42f4bca Mon Sep 17 00:00:00 2001
|
||||
From: Igor Raits <i.gnatenko.brain@gmail.com>
|
||||
Date: Sat, 22 Feb 2020 19:11:32 +0100
|
||||
Subject: [PATCH] chore: Update pulldown-cmark to 0.7
|
||||
|
||||
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
src/markdown_deps.rs | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/markdown_deps.rs b/src/markdown_deps.rs
|
||||
index a557c1c..01c45b3 100644
|
||||
--- a/src/markdown_deps.rs
|
||||
+++ b/src/markdown_deps.rs
|
||||
@@ -1,4 +1,4 @@
|
||||
-use pulldown_cmark::{Event, Parser, Tag};
|
||||
+use pulldown_cmark::{CodeBlockKind, Event, Parser, Tag};
|
||||
use semver_parser::range::parse as parse_request;
|
||||
use semver_parser::range::VersionReq;
|
||||
use semver_parser::version::parse as parse_version;
|
||||
@@ -63,7 +63,7 @@ fn find_toml_blocks(text: &str) -> Vec<CodeBlock<'_>> {
|
||||
let mut code_blocks = Vec::new();
|
||||
for (event, range) in parser.into_offset_iter() {
|
||||
match event {
|
||||
- Event::Start(Tag::CodeBlock(ref lang)) if is_toml_block(lang) => {
|
||||
+ Event::Start(Tag::CodeBlock(CodeBlockKind::Fenced(ref lang))) if is_toml_block(lang) => {
|
||||
let line_count = text[..range.start].lines().count();
|
||||
let code_block = &text[range];
|
||||
let start = 1 + code_block.find('\n').unwrap_or(0);
|
||||
--
|
||||
2.25.0
|
||||
|
@ -0,0 +1,34 @@
|
||||
From 33dc77fda8c5d993abee4e6c31c7526408877003 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Geisler <martin@geisler.net>
|
||||
Date: Wed, 11 Sep 2019 11:17:36 +0100
|
||||
Subject: [PATCH] markdown_deps: handle test output from toml 0.5.3
|
||||
|
||||
The latest minor version of the toml crate seems to give more detailed
|
||||
error output.
|
||||
---
|
||||
src/markdown_deps.rs | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/markdown_deps.rs b/src/markdown_deps.rs
|
||||
index 00ca12b..a557c1c 100644
|
||||
--- a/src/markdown_deps.rs
|
||||
+++ b/src/markdown_deps.rs
|
||||
@@ -276,10 +276,11 @@ mod tests {
|
||||
let block = "[dependencies]\n\
|
||||
foobar = 1.5.8";
|
||||
let request = extract_version_request("foobar", block);
|
||||
- assert_eq!(
|
||||
- request.unwrap_err(),
|
||||
- "TOML parse error: expected newline, found a period at line 2"
|
||||
- );
|
||||
+ // toml 0.5.3 returns "found a period at line 2 column 13.
|
||||
+ // Update the test when we bump the toml crate dependency.
|
||||
+ assert!(request
|
||||
+ .unwrap_err()
|
||||
+ .contains("TOML parse error: expected newline, found a period at line 2"));
|
||||
}
|
||||
|
||||
#[test]
|
||||
--
|
||||
2.24.0
|
||||
|
Binary file not shown.
@ -0,0 +1,11 @@
|
||||
--- version-sync-0.8.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ version-sync-0.8.1/Cargo.toml 2020-12-25T11:01:49.055308+00:00
|
||||
@@ -31,7 +31,7 @@
|
||||
features = ["span-locations"]
|
||||
|
||||
[dependencies.pulldown-cmark]
|
||||
-version = "0.4"
|
||||
+version = "0.8"
|
||||
default-features = false
|
||||
|
||||
[dependencies.regex]
|
@ -0,0 +1,100 @@
|
||||
# Generated by rust2rpm 16
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate version-sync
|
||||
|
||||
Name: rust-%{crate}0.8
|
||||
Version: 0.8.1
|
||||
Release: 6%{?dist}
|
||||
Summary: Simple crate for ensuring that version numbers in README files are updated
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/version-sync
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * Update pulldown-cmark to 0.8
|
||||
Patch0: version-sync-fix-metadata.diff
|
||||
# * Fix tests with toml 0.5.3+, https://github.com/mgeisler/version-sync/commit/33dc77fda8c5d993abee4e6c31c7526408877003
|
||||
Patch0001: 0001-markdown_deps-handle-test-output-from-toml-0.5.3.patch
|
||||
Patch0002: 0001-chore-Update-pulldown-cmark-to-0.7.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Simple crate for ensuring that version numbers in README files are updated when
|
||||
the crate version changes.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.8.1-6
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Fri Dec 25 12:01:49 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.8.1-2
|
||||
- Update pulldown-cmark to 0.8
|
||||
|
||||
* Sat Aug 29 19:44:45 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.8.1-1
|
||||
- Initial package
|
Loading…
Reference in new issue