parent
7741fdffe5
commit
6ef0f8d684
@ -0,0 +1 @@
|
||||
/version-sync-0.4.0.crate
|
@ -0,0 +1,69 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate version-sync
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.4.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Simple crate for ensuring that version numbers in README files are updated
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/version-sync
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * Bump itertools to 0.7
|
||||
# * Bump pulldown-cmark to 0.1
|
||||
# * Remove unicode-bidi requirement
|
||||
# https://github.com/mgeisler/version-sync/pull/30
|
||||
Patch0: version-sync-0.4.0-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(itertools) >= 0.7.0 with crate(itertools) < 0.8.0)
|
||||
BuildRequires: (crate(pulldown-cmark) >= 0.1.0 with crate(pulldown-cmark) < 0.2.0)
|
||||
BuildRequires: (crate(semver-parser) >= 0.7.0 with crate(semver-parser) < 0.8.0)
|
||||
BuildRequires: ((crate(syn) >= 0.11.0 with crate(syn) < 0.12.0) with crate(syn/full))
|
||||
BuildRequires: (crate(toml) >= 0.4.0 with crate(toml) < 0.5.0)
|
||||
BuildRequires: (crate(url) >= 1.5.1 with crate(url) < 2.0.0)
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Simple crate for ensuring that version numbers in README files are
|
||||
updated when the crate version changes.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Mon Nov 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-1
|
||||
- Initial package
|
@ -0,0 +1 @@
|
||||
SHA512 (version-sync-0.4.0.crate) = 508389e45b422022602d087415e6ee9321f854da3e5bdacda34294c59da6eb2c0271619a87a2bdd1094dfcb4f7822bc070855044739f34d9a4aa14e7ad30cbad
|
@ -0,0 +1,25 @@
|
||||
--- version-sync-0.4.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ version-sync-0.4.0/Cargo.toml 2017-11-13T18:27:41.999361+01:00
|
||||
@@ -23,10 +23,10 @@
|
||||
license = "MIT"
|
||||
repository = "https://github.com/mgeisler/version-sync"
|
||||
[dependencies.itertools]
|
||||
-version = "0.6.3"
|
||||
+version = "0.7"
|
||||
|
||||
[dependencies.pulldown-cmark]
|
||||
-version = "0.0.11"
|
||||
+version = "0.1"
|
||||
default-features = false
|
||||
|
||||
[dependencies.semver-parser]
|
||||
@@ -39,9 +39,6 @@
|
||||
[dependencies.toml]
|
||||
version = "0.4"
|
||||
|
||||
-[dependencies.unicode-bidi]
|
||||
-version = "0.3.1, < 0.3.4"
|
||||
-
|
||||
[dependencies.url]
|
||||
version = "1.5.1"
|
||||
[badges.appveyor]
|
Loading…
Reference in new issue