Update to 0.8.2

epel9
Josh Stone 5 years ago
parent 5113278e6f
commit cf06b27cdb

1
.gitignore vendored

@ -1,2 +1,3 @@
/vec_map-0.8.0.crate
/vec_map-0.8.1.crate
/vec_map-0.8.2.crate

@ -1,21 +1,18 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 13
%bcond_without check
%global debug_package %{nil}
%global crate vec_map
Name: rust-%{crate}
Version: 0.8.1
Release: 10%{?dist}
Version: 0.8.2
Release: 1%{?dist}
Summary: Simple map based on a vector for small integer keys
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/vec_map
Source: %{crates_source}
# Initial patched metadata
# * Exclude unneeded files, https://github.com/contain-rs/vec-map/pull/41
Patch0: vec_map-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -41,7 +38,7 @@ which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -53,7 +50,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+eders-devel
Summary: %{summary}
@ -65,7 +62,7 @@ This package contains library source intended for building other packages
which use "eders" feature of "%{crate}" crate.
%files -n %{name}+eders-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
@ -77,7 +74,7 @@ This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -98,6 +95,9 @@ which use "serde" feature of "%{crate}" crate.
%endif
%changelog
* Wed May 06 2020 Josh Stone <jistone@redhat.com> - 0.8.2-1
- Update to 0.8.2
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (vec_map-0.8.1.crate) = 026cf10dc7ba98ae51dd312fc847cbaea41c25f0da5db6e0e22c2ecf75584bbf876d7bd96035fbbcf6696d702d5a3f25977e02a2d77cf519aa21e3ed05710e40
SHA512 (vec_map-0.8.2.crate) = 4f1ef59bc2c437e79f1f84fe021bce5aa8ccd581f500f3d5776913d5f17d45b03ccee64f5bd03d47656318cfc9344a1f4311079d471fa409a8e4e94c143973f9

@ -1,10 +0,0 @@
--- vec_map-0.8.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ vec_map-0.8.1/Cargo.toml 2019-03-10T10:33:15.430354+01:00
@@ -21,6 +21,7 @@
keywords = ["data-structures", "collections", "vecmap", "vec_map", "contain-rs"]
license = "MIT/Apache-2.0"
repository = "https://github.com/contain-rs/vec-map"
+exclude = ["/deploy-docs.sh"]
[dependencies.serde]
version = "1.0"
features = ["derive"]
Loading…
Cancel
Save