You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-vec1/rust-vec1.spec

144 lines
3.7 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate vec1
Name: rust-vec1
Version: 1.10.1
Release: %autorelease
Summary: Std Vec wrapper assuring that it has at least 1 element
License: MIT OR Apache-2.0
URL: https://crates.io/crates/vec1
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
A std Vec wrapper assuring that it has at least 1 element.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CONTRIBUTORS.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+smallvec-v1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+smallvec-v1-devel %{_description}
This package contains library source intended for building other packages which
use the "smallvec-v1" feature of the "%{crate}" crate.
%files -n %{name}+smallvec-v1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+smallvec-v1-write-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+smallvec-v1-write-devel %{_description}
This package contains library source intended for building other packages which
use the "smallvec-v1-write" feature of the "%{crate}" crate.
%files -n %{name}+smallvec-v1-write-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+smallvec_v1_-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+smallvec_v1_-devel %{_description}
This package contains library source intended for building other packages which
use the "smallvec_v1_" feature of the "%{crate}" crate.
%files -n %{name}+smallvec_v1_-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unstable-nightly-try-from-impl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unstable-nightly-try-from-impl-devel %{_description}
This package contains library source intended for building other packages which
use the "unstable-nightly-try-from-impl" feature of the "%{crate}" crate.
%files -n %{name}+unstable-nightly-try-from-impl-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog