commit
c762902600
Binary file not shown.
@ -0,0 +1,11 @@
|
||||
--- value-bag-1.4.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ value-bag-1.4.2/Cargo.toml 2023-11-03T11:32:26.728890+00:00
|
||||
@@ -75,8 +75,3 @@
|
||||
sval2 = ["value-bag-sval2"]
|
||||
test = ["std"]
|
||||
|
||||
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen]
|
||||
-version = "0.2"
|
||||
-
|
||||
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
|
||||
-version = "0.3"
|
@ -0,0 +1,255 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate value-bag
|
||||
|
||||
Name: rust-value-bag
|
||||
Version: 1.4.2
|
||||
Release: %autorelease
|
||||
Summary: Anonymous structured values
|
||||
|
||||
License: Apache-2.0 OR MIT
|
||||
URL: https://crates.io/crates/value-bag
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: value-bag-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Anonymous structured values.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "alloc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+alloc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+error-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+error-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "error" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+error-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+inline-i128-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+inline-i128-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "inline-i128" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+inline-i128-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+owned-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+owned-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "owned" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+owned-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde1-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde1-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde1" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde1-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+sval-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+sval-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "sval" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+sval-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+sval2-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+sval2-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "sval2" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+sval2-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+test-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+test-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "test" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+test-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+value-bag-serde1-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+value-bag-serde1-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "value-bag-serde1" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+value-bag-serde1-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+value-bag-sval2-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+value-bag-sval2-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "value-bag-sval2" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+value-bag-sval2-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Nov 19 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.4.2-1
|
||||
- Rebuilt for MSVSphere 9.2
|
||||
|
||||
* Tue Nov 07 2023 Fabio Valentini <decathorpe@gmail.com> - 1.4.2-1
|
||||
- Update to version 1.4.2; Fixes RHBZ#2244971
|
||||
|
||||
* Wed Jul 19 2023 Fabio Valentini <decathorpe@gmail.com> - 1.4.1-1
|
||||
- Update to version 1.4.1; Fixes RHBZ#2182546
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0~alpha.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Wed May 25 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.0~alpha.9-1
|
||||
- Update to version 1.0.0-alpha.9
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0~alpha.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Thu Nov 04 2021 Fabio Valentini <decathorpe@gmail.com> - 1.0.0~alpha.8-1
|
||||
- Update to version 1.0.0-alpha.8; Fixes RHBZ#2017344
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0~alpha.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Sun May 23 2021 Fabio Valentini <decathorpe@gmail.com> - 1.0.0~alpha.7-1
|
||||
- Update to version 1.0.0-alpha.7.
|
||||
- Fixes RHBZ#1960972
|
||||
|
||||
* Mon May 10 2021 Fabio Valentini <decathorpe@gmail.com> - 1.0.0~alpha.6-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue