You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-value-bag-sval2/rust-value-bag-sval2.spec

165 lines
4.1 KiB

# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate value-bag-sval2
Name: rust-value-bag-sval2
Version: 1.4.2
Release: %autorelease
Summary: Implementation detail for value-bag
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/value-bag-sval2
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Implementation detail for value-bag.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+json-devel %{_description}
This package contains library source intended for building other packages which
use the "json" feature of the "%{crate}" crate.
%files -n %{name}+json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde1-devel %{_description}
This package contains library source intended for building other packages which
use the "serde1" feature of the "%{crate}" crate.
%files -n %{name}+serde1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sval_json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sval_json-devel %{_description}
This package contains library source intended for building other packages which
use the "sval_json" feature of the "%{crate}" crate.
%files -n %{name}+sval_json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sval_serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sval_serde-devel %{_description}
This package contains library source intended for building other packages which
use the "sval_serde" feature of the "%{crate}" crate.
%files -n %{name}+sval_serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sval_test-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sval_test-devel %{_description}
This package contains library source intended for building other packages which
use the "sval_test" feature of the "%{crate}" crate.
%files -n %{name}+sval_test-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+test-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+test-devel %{_description}
This package contains library source intended for building other packages which
use the "test" feature of the "%{crate}" crate.
%files -n %{name}+test-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog