Update to version 0.3.4; Fixes RHBZ#2132091

epel9 imports/e9/rust-v_frame-0.3.4-1.el9
Fabio Valentini 2 years ago
parent 3c7ac6652f
commit b0dc246835
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/v_frame-0.2.0.crate
/v_frame-0.2.1.crate
/v_frame-0.2.5.crate
/v_frame-0.3.4.crate

@ -0,0 +1,32 @@
From 8a7af9959ad71192951c734e3c91aac5b29165c2 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Tue, 27 Jun 2023 19:32:07 +0200
Subject: [PATCH] remove noop hawktracer macros
---
src/plane.rs | 2 --
1 file changed, 2 deletions(-)
diff --git a/src/plane.rs b/src/plane.rs
index 7979edc..6e81a24 100644
--- a/src/plane.rs
+++ b/src/plane.rs
@@ -7,7 +7,6 @@
// Media Patent License 1.0 was not distributed with this source code in the
// PATENTS file, you can obtain it at www.aomedia.org/license/patent.
-use rust_hawktracer::*;
use std::alloc::handle_alloc_error;
use std::iter::FusedIterator;
use std::marker::PhantomData;
@@ -592,7 +591,6 @@ impl<T: Pixel> Plane<T> {
/// # Panics
///
/// - If the current plane's width and height are not at least `SCALE` times the `in_plane`'s
- #[hawktracer(downscale_in_place)]
pub fn downscale_in_place<const SCALE: usize>(&self, in_plane: &mut Plane<T>) {
let stride = in_plane.cfg.stride;
let width = in_plane.cfg.width;
--
2.41.0

@ -1,52 +0,0 @@
From e106ded8e5e29ee464bddc6a321fe67a8e5884c1 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Mon, 8 Aug 2022 20:15:48 +0200
Subject: [PATCH] remove unused hawktracer usage
---
src/lib.rs | 8 +-------
src/plane.rs | 2 --
2 files changed, 1 insertion(+), 9 deletions(-)
diff --git a/src/lib.rs b/src/lib.rs
index 298dc01..b4bc59a 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -23,13 +23,7 @@ mod serialize {
}
mod wasm_bindgen {
- cfg_if::cfg_if! {
- if #[cfg(feature="wasm")] {
- pub use wasm_bindgen::prelude::*;
- } else {
- pub use noop_proc_macro::wasm_bindgen;
- }
- }
+ pub use noop_proc_macro::wasm_bindgen;
}
pub mod prelude {
diff --git a/src/plane.rs b/src/plane.rs
index 7723d89..a09a708 100644
--- a/src/plane.rs
+++ b/src/plane.rs
@@ -10,7 +10,6 @@
use rayon::current_num_threads;
use rayon::iter::ParallelIterator;
use rayon::prelude::*;
-use rust_hawktracer::*;
use std::cmp;
use std::marker::PhantomData;
use std::mem;
@@ -559,7 +558,6 @@ impl<T: Pixel> Plane<T> {
/// Downscales the source plane by a factor of `scale`, writing the result to `in_plane` (not padded)
///
/// `in_plane`'s width and height must be sufficient for `scale`.
- #[hawktracer(downscale)]
pub fn downscale_in_place(&self, scale: usize, in_plane: &mut Plane<T>) {
let src = self;
let box_pixels = scale * scale;
--
2.37.1

@ -1,3 +0,0 @@
# rust-v_frame
The rust-v_frame package

@ -1,30 +1,28 @@
# Generated by rust2rpm 22
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate v_frame
Name: rust-v_frame
Version: 0.2.5
Version: 0.3.4
Release: %autorelease
Summary: Video Frame data structures, part of rav1e
Summary: Video Frame data structures, originally part of rav1e
License: BSD-2-Clause
URL: https://crates.io/crates/v_frame
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * remove unused WASM support / wasm-bindgen dependency
# * remove hawktracer dependency
# * drop unused, no-op rust_hawktracer dependency and tracing feature
# * drop WASM-specific wasm-bindgen dependency and wasm feature
# * drop unused, benchmark-only criterion dev-dependency
Patch: v_frame-fix-metadata.diff
# * remove useless / no-op hawktracer macros
Patch: 0001-remove-unused-hawktracer-usage.patch
ExclusiveArch: %{rust_arches}
Patch: 0001-remove-noop-hawktracer-macros.patch
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Video Frame data structures, part of rav1e.}
Video Frame data structures, originally part of rav1e.}
%description %{_description}
@ -39,6 +37,8 @@ use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel

@ -1 +1 @@
SHA512 (v_frame-0.2.5.crate) = cd883b644700dfc58cdb78a8932e8c981306120a5a9b3e6c616b5712213df09263ef354fd4d4227b6305977e099fca8b98dc599a8b483b2f74b3f8688011f54c
SHA512 (v_frame-0.3.4.crate) = 04dfe50c2aa23e0eee9b7a5075a46ca1aa2864e3e6e9e3831d3f0cfe38337e8b7ca7e22184d8af3af3c25d3afb2e59521654daff321885b3332e98b060d47b55

@ -1,8 +1,8 @@
--- v_frame-0.2.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ v_frame-0.2.5/Cargo.toml 2022-08-08T18:09:30.047054+00:00
@@ -32,19 +32,10 @@
[dependencies.rayon]
version = "1.0"
--- v_frame-0.3.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ v_frame-0.3.4/Cargo.toml 2023-06-27T17:27:48.196399+00:00
@@ -35,23 +35,10 @@
[dependencies.num-traits]
version = "0.2"
-[dependencies.rust_hawktracer]
-version = "0.7.0"
@ -15,6 +15,10 @@
-[dependencies.wasm-bindgen]
-version = "0.2.63"
-optional = true
-
-[dev-dependencies.criterion]
-version = "0.4"
-features = ["html_reports"]
-
[features]
serialize = ["serde"]

Loading…
Cancel
Save