parent
90c388a37f
commit
8a32334065
@ -0,0 +1 @@
|
||||
/v_frame-0.1.0.crate
|
@ -0,0 +1,101 @@
|
||||
# Generated by rust2rpm 16
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate v_frame
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Video Frame data structures, part of rav1e
|
||||
|
||||
# Upstream license specification: BSD-2-Clause
|
||||
# https://github.com/xiph/rav1e/issues/2610
|
||||
License: BSD
|
||||
URL: https://crates.io/crates/v_frame
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# - Bump noop_proc_macro to 0.3.0 (already upstream)
|
||||
Patch0: v_frame-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Video Frame data structures, part of rav1e.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "serde" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serialize-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serialize-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "serialize" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serialize-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Dec 10 08:55:10 CET 2020 Robert-André Mauchin <zebob.m@gmail.com> - 0.1.0-1
|
||||
- Initial package
|
@ -0,0 +1 @@
|
||||
SHA512 (v_frame-0.1.0.crate) = d5959f04600f5d4705f6d0abf7e4a626f8d83baff451bf694d316c05f6b902660d7ddcf65c67fc23a9fe8175381030c3e01cc7787e0b775c367281786b6dfb4b
|
@ -0,0 +1,11 @@
|
||||
--- v_frame-0.1.0/Cargo.toml 2020-02-26T19:26:16+00:00
|
||||
+++ v_frame-0.1.0/Cargo.toml 2020-12-10T07:55:10.619044+00:00
|
||||
@@ -22,7 +22,7 @@
|
||||
version = "0.1"
|
||||
|
||||
[dependencies.noop_proc_macro]
|
||||
-version = "0.2.0"
|
||||
+version = "0.3.0"
|
||||
|
||||
[dependencies.num-derive]
|
||||
version = "0.3"
|
Loading…
Reference in new issue