import rust-v_frame-0.3.4-1.el9

i9 changed/i9/rust-v_frame-0.3.4-1.el9
Arkady L. Shane 1 year ago
commit 6d22ffc34a
Signed by: tigro
GPG Key ID: 9C7900103E1C4F8B

@ -0,0 +1,32 @@
From 8a7af9959ad71192951c734e3c91aac5b29165c2 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Tue, 27 Jun 2023 19:32:07 +0200
Subject: [PATCH] remove noop hawktracer macros
---
src/plane.rs | 2 --
1 file changed, 2 deletions(-)
diff --git a/src/plane.rs b/src/plane.rs
index 7979edc..6e81a24 100644
--- a/src/plane.rs
+++ b/src/plane.rs
@@ -7,7 +7,6 @@
// Media Patent License 1.0 was not distributed with this source code in the
// PATENTS file, you can obtain it at www.aomedia.org/license/patent.
-use rust_hawktracer::*;
use std::alloc::handle_alloc_error;
use std::iter::FusedIterator;
use std::marker::PhantomData;
@@ -592,7 +591,6 @@ impl<T: Pixel> Plane<T> {
/// # Panics
///
/// - If the current plane's width and height are not at least `SCALE` times the `in_plane`'s
- #[hawktracer(downscale_in_place)]
pub fn downscale_in_place<const SCALE: usize>(&self, in_plane: &mut Plane<T>) {
let stride = in_plane.cfg.stride;
let width = in_plane.cfg.width;
--
2.41.0

Binary file not shown.

@ -0,0 +1,26 @@
--- v_frame-0.3.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ v_frame-0.3.4/Cargo.toml 2023-06-27T17:27:48.196399+00:00
@@ -35,23 +35,10 @@
[dependencies.num-traits]
version = "0.2"
-[dependencies.rust_hawktracer]
-version = "0.7.0"
-
[dependencies.serde]
version = "1.0"
features = ["derive"]
optional = true
-[dependencies.wasm-bindgen]
-version = "0.2.63"
-optional = true
-
-[dev-dependencies.criterion]
-version = "0.4"
-features = ["html_reports"]
-
[features]
serialize = ["serde"]
-tracing = ["rust_hawktracer/profiling_enabled"]
-wasm = ["wasm-bindgen"]

@ -0,0 +1,144 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate v_frame
Name: rust-v_frame
Version: 0.3.4
Release: %autorelease
Summary: Video Frame data structures, originally part of rav1e
License: BSD-2-Clause
URL: https://crates.io/crates/v_frame
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, no-op rust_hawktracer dependency and tracing feature
# * drop WASM-specific wasm-bindgen dependency and wasm feature
# * drop unused, benchmark-only criterion dev-dependency
Patch: v_frame-fix-metadata.diff
Patch: 0001-remove-noop-hawktracer-macros.patch
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Video Frame data structures, originally part of rav1e.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serialize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serialize-devel %{_description}
This package contains library source intended for building other packages which
use the "serialize" feature of the "%{crate}" crate.
%files -n %{name}+serialize-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Oct 13 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.3.4-1
- Rebuilt for MSVSphere 9.2
* Tue Jun 27 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.4-1
- Update to version 0.3.4; Fixes RHBZ#2132091
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.5-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Mon Aug 08 2022 Fabio Valentini <decathorpe@gmail.com> - 0.2.5-4
- Remove unused dependencies on wasm-bindgen and hawktracer
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Sun Nov 14 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.5-1
- Update to 0.2.5 Close: rhbz#1991571
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Apr 7 17:23:55 CEST 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.1-1
- Update to 0.2.1
* Mon Mar 29 16:26:18 CEST 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.0-1
- Update to 0.2.0
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Thu Dec 10 08:55:10 CET 2020 Robert-André Mauchin <zebob.m@gmail.com> - 0.1.0-1
- Initial package
Loading…
Cancel
Save