You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-uzers/rust-uzers.spec

118 lines
2.8 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate uzers
Name: rust-uzers
Version: 0.11.3
Release: %autorelease
Summary: Library for accessing Unix users and groups
License: MIT
URL: https://crates.io/crates/uzers
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Continuation of users, a library for accessing Unix users and groups.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENCE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cache-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cache-devel %{_description}
This package contains library source intended for building other packages which
use the "cache" feature of the "%{crate}" crate.
%files -n %{name}+cache-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages which
use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+logging-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+logging-devel %{_description}
This package contains library source intended for building other packages which
use the "logging" feature of the "%{crate}" crate.
%files -n %{name}+logging-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mock-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mock-devel %{_description}
This package contains library source intended for building other packages which
use the "mock" feature of the "%{crate}" crate.
%files -n %{name}+mock-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog