You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
51 lines
944 B
51 lines
944 B
--- uuid-1.9.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
+++ uuid-1.9.1/Cargo.toml 2024-07-06T01:35:23.157191+00:00
|
|
@@ -88,16 +88,6 @@
|
|
optional = true
|
|
default-features = false
|
|
|
|
-[dependencies.borsh]
|
|
-version = "1"
|
|
-optional = true
|
|
-default-features = false
|
|
-
|
|
-[dependencies.borsh-derive]
|
|
-version = "1"
|
|
-optional = true
|
|
-default-features = false
|
|
-
|
|
[dependencies.bytemuck]
|
|
version = "1.14.0"
|
|
features = ["derive"]
|
|
@@ -130,10 +120,6 @@
|
|
version = "2"
|
|
optional = true
|
|
|
|
-[dependencies.uuid-macro-internal]
|
|
-version = "1.9.1"
|
|
-optional = true
|
|
-
|
|
[dependencies.zerocopy]
|
|
version = "0.7"
|
|
features = ["derive"]
|
|
@@ -159,19 +145,11 @@
|
|
|
|
[features]
|
|
atomic = ["dep:atomic"]
|
|
-borsh = [
|
|
- "dep:borsh",
|
|
- "dep:borsh-derive",
|
|
-]
|
|
default = ["std"]
|
|
fast-rng = [
|
|
"rng",
|
|
"dep:rand",
|
|
]
|
|
-js = [
|
|
- "getrandom?/js",
|
|
-]
|
|
-macro-diagnostics = ["dep:uuid-macro-internal"]
|
|
md5 = ["dep:md-5"]
|
|
rng = ["dep:getrandom"]
|
|
sha1 = ["dep:sha1_smol"]
|