You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-uuid/uuid-fix-metadata.diff

59 lines
1.2 KiB

--- uuid-1.1.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.1.1/Cargo.toml 2022-06-05T11:11:54.627508+00:00
@@ -90,11 +90,6 @@
default-features = false
package = "sha1_smol"
-[dependencies.private_uuid-macro-internal]
-version = "1.1.1"
-optional = true
-package = "uuid-macro-internal"
-
[dependencies.serde]
version = "1.0.56"
optional = true
@@ -102,10 +97,6 @@
[dependencies.slog]
version = "2"
-optional = true
-
-[dependencies.zerocopy]
-version = "0.6"
optional = true
[dev-dependencies.bincode]
@@ -132,11 +123,6 @@
"rng",
"private_rand",
]
-js = [
- "private_getrandom",
- "private_getrandom/js",
-]
-macro-diagnostics = ["private_uuid-macro-internal"]
md5 = ["private_md-5"]
rng = ["private_getrandom"]
sha1 = ["private_sha1_smol"]
@@ -145,20 +131,6 @@
v3 = ["md5"]
v4 = ["rng"]
v5 = ["sha1"]
-
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-lib]
-version = "0.2"
-package = "wasm-bindgen"
-
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target."cfg(windows)".dev-dependencies.winapi]
-version = "0.3"
-features = [
- "combaseapi",
- "impl-default",
-]
[badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid"