You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-uuid/rust-uuid.spec

333 lines
8.9 KiB

# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate uuid
Name: rust-uuid
Version: 1.6.1
Release: %autorelease
Summary: Library to generate and parse UUIDs
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/uuid
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: uuid-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused optional dependency for borsh support
# * drop WASM-specific features and dependencies
# * drop internal-only features
Patch: uuid-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A library to generate and parse UUIDs.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/SECURITY.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arbitrary-devel %{_description}
This package contains library source intended for building other packages which
use the "arbitrary" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+atomic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+atomic-devel %{_description}
This package contains library source intended for building other packages which
use the "atomic" feature of the "%{crate}" crate.
%files -n %{name}+atomic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytemuck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytemuck-devel %{_description}
This package contains library source intended for building other packages which
use the "bytemuck" feature of the "%{crate}" crate.
%files -n %{name}+bytemuck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fast-rng-devel %{_description}
This package contains library source intended for building other packages which
use the "fast-rng" feature of the "%{crate}" crate.
%files -n %{name}+fast-rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages which
use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+getrandom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+md-5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+md-5-devel %{_description}
This package contains library source intended for building other packages which
use the "md-5" feature of the "%{crate}" crate.
%files -n %{name}+md-5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+md5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+md5-devel %{_description}
This package contains library source intended for building other packages which
use the "md5" feature of the "%{crate}" crate.
%files -n %{name}+md5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rng-devel %{_description}
This package contains library source intended for building other packages which
use the "rng" feature of the "%{crate}" crate.
%files -n %{name}+rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1-devel %{_description}
This package contains library source intended for building other packages which
use the "sha1" feature of the "%{crate}" crate.
%files -n %{name}+sha1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha1_smol-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1_smol-devel %{_description}
This package contains library source intended for building other packages which
use the "sha1_smol" feature of the "%{crate}" crate.
%files -n %{name}+sha1_smol-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+slog-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+slog-devel %{_description}
This package contains library source intended for building other packages which
use the "slog" feature of the "%{crate}" crate.
%files -n %{name}+slog-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v1-devel %{_description}
This package contains library source intended for building other packages which
use the "v1" feature of the "%{crate}" crate.
%files -n %{name}+v1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v3-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v3-devel %{_description}
This package contains library source intended for building other packages which
use the "v3" feature of the "%{crate}" crate.
%files -n %{name}+v3-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v4-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v4-devel %{_description}
This package contains library source intended for building other packages which
use the "v4" feature of the "%{crate}" crate.
%files -n %{name}+v4-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v5-devel %{_description}
This package contains library source intended for building other packages which
use the "v5" feature of the "%{crate}" crate.
%files -n %{name}+v5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v6-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v6-devel %{_description}
This package contains library source intended for building other packages which
use the "v6" feature of the "%{crate}" crate.
%files -n %{name}+v6-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v7-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v7-devel %{_description}
This package contains library source intended for building other packages which
use the "v7" feature of the "%{crate}" crate.
%files -n %{name}+v7-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v8-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v8-devel %{_description}
This package contains library source intended for building other packages which
use the "v8" feature of the "%{crate}" crate.
%files -n %{name}+v8-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog