Bump rand, md5 to 0.6

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 28adb53bd0
commit f4531741f5
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -7,7 +7,7 @@
Name: rust-%{crate}
Version: 0.7.1
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Library to generate and parse UUIDs
# Upstream license specification: Apache-2.0 OR MIT
@ -16,14 +16,16 @@ URL: https://crates.io/crates/uuid
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Drop slog dependency until packaged
# * Bump rand to 0.6
# * Bump md5 to 0.6
Patch0: uuid-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(byteorder/i128) >= 1.0.0 with crate(byteorder/i128) < 2.0.0)
BuildRequires: (crate(md5/default) >= 0.3.0 with crate(md5/default) < 0.4.0)
BuildRequires: (crate(rand/default) >= 0.5.0 with crate(rand/default) < 0.6.0)
BuildRequires: (crate(md5/default) >= 0.6.0 with crate(md5/default) < 0.7.0)
BuildRequires: (crate(rand/default) >= 0.6.0 with crate(rand/default) < 0.7.0)
BuildRequires: (crate(serde) >= 1.0.56 with crate(serde) < 2.0.0)
BuildRequires: (crate(sha1/default) >= 0.6.0 with crate(sha1/default) < 0.7.0)
%if %{with check}
@ -213,6 +215,9 @@ chmod -x benches/*.rs
%endif
%changelog
* Tue Dec 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-3
- Bump rand, md5 to 0.6
* Sat Dec 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-2
- Run tests in infrastructure

@ -1,5 +1,19 @@
--- uuid-0.7.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ uuid-0.7.1/Cargo.toml 2018-11-20T19:52:33.354300+01:00
+++ uuid-0.7.1/Cargo.toml 2018-12-11T11:50:17.034371+01:00
@@ -33,11 +33,11 @@
default-features = false
[dependencies.md5]
-version = "0.3"
+version = "0.6"
optional = true
[dependencies.rand]
-version = "0.5"
+version = "0.6"
optional = true
[dependencies.serde]
@@ -49,9 +49,6 @@
version = "0.6"
optional = true

Loading…
Cancel
Save