update to version 0.8.2

epel9
Fabio Valentini 4 years ago
parent e0c40b862a
commit b7f7046817
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -7,3 +7,4 @@
/uuid-0.7.3.crate
/uuid-0.7.4.crate
/uuid-0.8.1.crate
/uuid-0.8.2.crate

@ -1,12 +1,12 @@
# Generated by rust2rpm 13
# Generated by rust2rpm 16
%bcond_without check
%global debug_package %{nil}
%global crate uuid
Name: rust-%{crate}
Version: 0.8.1
Release: 4%{?dist}
Version: 0.8.2
Release: 1%{?dist}
Summary: Library to generate and parse UUIDs
# Upstream license specification: Apache-2.0 OR MIT
@ -15,7 +15,6 @@ URL: https://crates.io/crates/uuid
Source: %{crates_source}
# Initial patched metadata
# * No windows
# * Bump to md5 0.7, https://github.com/uuid-rs/uuid/pull/442
Patch0: uuid-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -56,28 +55,28 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+md5-devel
%package -n %{name}+getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+md5-devel %{_description}
%description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages
which use "md5" feature of "%{crate}" crate.
which use "getrandom" feature of "%{crate}" crate.
%files -n %{name}+md5-devel
%files -n %{name}+getrandom-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rand-devel
%package -n %{name}+md5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
%description -n %{name}+md5-devel %{_description}
This package contains library source intended for building other packages
which use "rand" feature of "%{crate}" crate.
which use "md5" feature of "%{crate}" crate.
%files -n %{name}+rand-devel
%files -n %{name}+md5-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel
@ -195,6 +194,10 @@ which use "v5" feature of "%{crate}" crate.
%endif
%changelog
* Mon Jan 11 2021 Fabio Valentini <decathorpe@gmail.com> - 0.8.2-1
- Update to version 0.8.2.
- Fixes RHBZ#1914753
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

@ -1 +1 @@
SHA512 (uuid-0.8.1.crate) = 754cd59021053cd3ec6b929cf6ed15127a8d0d9be1777e100153d6a23160a251c146eb180fccd1e515d1d0728332bbdb7c36e8f111958489234db6299df28f7c
SHA512 (uuid-0.8.2.crate) = 5a1f5ead9a920b9bbc120c02049c24b62ec215765e486d3a15c5015ef49fa506206efb737e6f6555cf6e2eddddfe55f0ca1d7dcfa9aa8bcf3e0ef570a54fa2d8

@ -1,26 +1,17 @@
--- uuid-0.8.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ uuid-0.8.1/Cargo.toml 2020-01-16T22:06:38.036466+00:00
@@ -31,7 +31,7 @@
[package.metadata.playground]
features = ["serde", "v1", "v3", "v4", "v5"]
[dependencies.md5]
-version = "0.6"
+version = "0.7"
optional = true
[dependencies.rand]
@@ -65,17 +65,11 @@
--- uuid-0.8.2/Cargo.toml 2021-01-11T06:19:14+00:00
+++ uuid-0.8.2/Cargo.toml 2021-01-11T09:40:05.846404+00:00
@@ -64,17 +64,11 @@
[features]
default = ["std"]
-guid = ["winapi"]
std = []
-stdweb = ["rand/stdweb"]
-stdweb = ["getrandom", "getrandom/js"]
v1 = []
v3 = ["md5"]
v4 = ["rand"]
v4 = ["getrandom"]
v5 = ["sha1"]
-wasm-bindgen = ["rand/wasm-bindgen"]
-wasm-bindgen = ["getrandom", "getrandom/js"]
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-optional = true

Loading…
Cancel
Save