Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent a51b9bf964
commit b1a4f9b70d
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,6 +1,5 @@
# Generated by rust2rpm
# * Tests are run in infrastructure
%bcond_with check
# Generated by rust2rpm 10
%bcond_without check
%global debug_package %{nil}
%global crate uuid
@ -14,19 +13,19 @@ Summary: Library to generate and parse UUIDs
License: ASL 2.0 or MIT
URL: https://crates.io/crates/uuid
Source: %{crates_source}
# Initial patched metadata
# * No windows
Patch0: uuid-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%if %{with check}
BuildRequires: (crate(bincode/default) >= 1.0.0 with crate(bincode/default) < 2.0.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.79 with crate(serde_derive/default) < 2.0.0)
BuildRequires: (crate(serde_json/default) >= 1.0.0 with crate(serde_json/default) < 2.0.0)
BuildRequires: (crate(serde_test/default) >= 1.0.56 with crate(serde_test/default) < 2.0.0)
%endif
%global _description \
A library to generate and parse UUIDs.
%global _description %{expand:
Library to generate and parse UUIDs.}
%description %{_description}
@ -68,6 +67,18 @@ which use "byteorder" feature of "%{crate}" crate.
%files -n %{name}+byteorder-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+const_fn-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+const_fn-devel %{_description}
This package contains library source intended for building other packages
which use "const_fn" feature of "%{crate}" crate.
%files -n %{name}+const_fn-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+md5-devel
Summary: %{summary}
BuildArch: noarch
@ -80,6 +91,18 @@ which use "md5" feature of "%{crate}" crate.
%files -n %{name}+md5-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages
which use "nightly" feature of "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
@ -140,6 +163,18 @@ which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+stdweb-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+stdweb-devel %{_description}
This package contains library source intended for building other packages
which use "stdweb" feature of "%{crate}" crate.
%files -n %{name}+stdweb-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+u128-devel
Summary: %{summary}
BuildArch: noarch
@ -200,10 +235,25 @@ which use "v5" feature of "%{crate}" crate.
%files -n %{name}+v5-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+wasm-bindgen-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+wasm-bindgen-devel %{_description}
This package contains library source intended for building other packages
which use "wasm-bindgen" feature of "%{crate}" crate.
%files -n %{name}+wasm-bindgen-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
@ -216,6 +266,9 @@ which use "v5" feature of "%{crate}" crate.
%endif
%changelog
* Sat Jun 22 10:18:57 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-2
- Regenerate
* Fri Mar 29 15:50:41 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-1
- Update to 0.7.4

@ -0,0 +1,20 @@
--- uuid-0.7.4/Cargo.toml 1970-01-01T00:00:00+00:00
+++ uuid-0.7.4/Cargo.toml 2019-06-22T08:18:57.093112+00:00
@@ -68,7 +68,6 @@
[features]
const_fn = ["nightly"]
default = ["std"]
-guid = ["winapi"]
nightly = []
std = []
stdweb = ["rand/stdweb"]
@@ -78,9 +77,6 @@
v4 = ["rand"]
v5 = ["sha1"]
wasm-bindgen = ["rand/wasm-bindgen"]
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-optional = true
[badges.appveyor]
repository = "uuid-rs/uuid"
Loading…
Cancel
Save