Update to version 1.4.0; Fixes RHBZ#2217791

epel9
Fabio Valentini 2 years ago
parent 9c59c3a8b8
commit af6cf664af
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -18,3 +18,4 @@
/uuid-1.3.2.crate
/uuid-1.3.3.crate
/uuid-1.3.4.crate
/uuid-1.4.0.crate

@ -5,7 +5,7 @@
%global crate uuid
Name: rust-uuid
Version: 1.3.4
Version: 1.4.0
Release: %autorelease
Summary: Library to generate and parse UUIDs
@ -15,6 +15,7 @@ Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: uuid-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused optional dependency for borsh support
# * drop WASM-specific features and dependencies
# * drop internal-only features
Patch: uuid-fix-metadata.diff

@ -1 +1 @@
SHA512 (uuid-1.3.4.crate) = 42eb9c8f39f4424b1a40669eb8abd7d81b0bf1020a3433aa34f2022eb62facf4796462cfe2e6fba69c1e5ec63a2f81c1dda72094aaa0fdeb2bbf83acd43c6899
SHA512 (uuid-1.4.0.crate) = 92acf08ee1f36a3a394422ce9b1cdbe0ccf3fb8d878efe068fd025832af677466622bd1260e853c5232f18b4f5411136595aa07311a3f9886904800bee7cfaa0

@ -1,16 +1,16 @@
--- uuid-1.3.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.3.4/Cargo.toml 2023-06-23T21:50:50.179657+00:00
@@ -173,17 +173,6 @@
--- uuid-1.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.4.0/Cargo.toml 2023-07-15T14:01:36.550951+00:00
@@ -178,17 +178,6 @@
]
v8 = []
-[target."cfg(all(target_arch = \"wasm32\", target_vendor = \"unknown\", target_os = \"unknown\"))".dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target."cfg(target = \"wasm32-unknown-unknown\")".dev-dependencies.wasm-bindgen]
-version = "0.2"
-package = "wasm-bindgen"
-
-[target."cfg(target = \"wasm32-unknown-unknown\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target."cfg(windows)".dev-dependencies.windows-sys]
-version = "0.48.0"
-features = ["Win32_System_Com"]

@ -1,11 +1,22 @@
--- uuid-1.3.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.3.4/Cargo.toml 2023-06-23T21:51:15.198751+00:00
@@ -114,20 +114,6 @@
--- uuid-1.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.4.0/Cargo.toml 2023-07-15T14:01:58.729036+00:00
@@ -84,10 +84,6 @@
default-features = false
package = "atomic"
-[dependencies.borsh]
-version = "0.10.3"
-optional = true
-
[dependencies.getrandom]
version = "0.2"
optional = true
@@ -119,20 +115,6 @@
version = "2"
optional = true
-[dependencies.uuid-macro-internal]
-version = "1.3.4"
-version = "1.4.0"
-optional = true
-package = "uuid-macro-internal"
-
@ -21,7 +32,7 @@
[dev-dependencies.bincode]
version = "1.0"
@@ -152,12 +138,6 @@
@@ -157,12 +139,6 @@
"rng",
"rand",
]

Loading…
Cancel
Save