import rust-uuid-1.5.0-1.el9

i9ce changed/i9ce/rust-uuid-1.5.0-1.el9
Arkady L. Shane 1 year ago
commit acd265bf14
Signed by: tigro
GPG Key ID: 8D1597B4AD3AFAA0

Binary file not shown.

@ -0,0 +1,25 @@
--- uuid-1.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.5.0/Cargo.toml 2023-10-19T14:36:57.156620+00:00
@@ -184,17 +184,6 @@
]
v8 = []
-[target."cfg(all(target_arch = \"wasm32\", target_vendor = \"unknown\", target_os = \"unknown\"))".dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target."cfg(target = \"wasm32-unknown-unknown\")".dev-dependencies.wasm-bindgen]
-version = "0.2"
-package = "wasm-bindgen"
-
-[target."cfg(windows)".dev-dependencies.windows-sys]
-version = "0.48.0"
-features = ["Win32_System_Com"]
-
[badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid"
@@ -203,3 +192,4 @@
[badges.maintenance]
status = "actively-developed"
+

@ -0,0 +1,47 @@
--- uuid-1.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.5.0/Cargo.toml 2023-10-19T14:37:41.348829+00:00
@@ -85,10 +85,6 @@
default-features = false
package = "atomic"
-[dependencies.borsh]
-version = "0.10.3"
-optional = true
-
[dependencies.bytemuck]
version = "1.14.0"
features = ["derive"]
@@ -125,20 +121,6 @@
version = "2"
optional = true
-[dependencies.uuid-macro-internal]
-version = "1.5.0"
-optional = true
-package = "uuid-macro-internal"
-
-[dependencies.wasm-bindgen]
-version = "0.2"
-optional = true
-package = "wasm-bindgen"
-
-[dependencies.zerocopy]
-version = "0.6"
-optional = true
-
[dev-dependencies.bincode]
version = "1.0"
@@ -163,12 +145,6 @@
"rng",
"rand",
]
-js = [
- "wasm-bindgen",
- "getrandom",
- "getrandom/js",
-]
-macro-diagnostics = ["uuid-macro-internal"]
md5 = ["md-5"]
rng = ["getrandom"]
sha1 = ["sha1_smol"]

@ -0,0 +1,478 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate uuid
Name: rust-uuid
Version: 1.5.0
Release: %autorelease
Summary: Library to generate and parse UUIDs
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/uuid
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: uuid-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused optional dependency for borsh support
# * drop WASM-specific features and dependencies
# * drop internal-only features
Patch: uuid-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A library to generate and parse UUIDs.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/SECURITY.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arbitrary-devel %{_description}
This package contains library source intended for building other packages which
use the "arbitrary" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+atomic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+atomic-devel %{_description}
This package contains library source intended for building other packages which
use the "atomic" feature of the "%{crate}" crate.
%files -n %{name}+atomic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytemuck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytemuck-devel %{_description}
This package contains library source intended for building other packages which
use the "bytemuck" feature of the "%{crate}" crate.
%files -n %{name}+bytemuck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fast-rng-devel %{_description}
This package contains library source intended for building other packages which
use the "fast-rng" feature of the "%{crate}" crate.
%files -n %{name}+fast-rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages which
use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+getrandom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+md-5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+md-5-devel %{_description}
This package contains library source intended for building other packages which
use the "md-5" feature of the "%{crate}" crate.
%files -n %{name}+md-5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+md5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+md5-devel %{_description}
This package contains library source intended for building other packages which
use the "md5" feature of the "%{crate}" crate.
%files -n %{name}+md5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rng-devel %{_description}
This package contains library source intended for building other packages which
use the "rng" feature of the "%{crate}" crate.
%files -n %{name}+rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1-devel %{_description}
This package contains library source intended for building other packages which
use the "sha1" feature of the "%{crate}" crate.
%files -n %{name}+sha1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha1_smol-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1_smol-devel %{_description}
This package contains library source intended for building other packages which
use the "sha1_smol" feature of the "%{crate}" crate.
%files -n %{name}+sha1_smol-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+slog-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+slog-devel %{_description}
This package contains library source intended for building other packages which
use the "slog" feature of the "%{crate}" crate.
%files -n %{name}+slog-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v1-devel %{_description}
This package contains library source intended for building other packages which
use the "v1" feature of the "%{crate}" crate.
%files -n %{name}+v1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v3-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v3-devel %{_description}
This package contains library source intended for building other packages which
use the "v3" feature of the "%{crate}" crate.
%files -n %{name}+v3-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v4-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v4-devel %{_description}
This package contains library source intended for building other packages which
use the "v4" feature of the "%{crate}" crate.
%files -n %{name}+v4-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v5-devel %{_description}
This package contains library source intended for building other packages which
use the "v5" feature of the "%{crate}" crate.
%files -n %{name}+v5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v6-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v6-devel %{_description}
This package contains library source intended for building other packages which
use the "v6" feature of the "%{crate}" crate.
%files -n %{name}+v6-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v7-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v7-devel %{_description}
This package contains library source intended for building other packages which
use the "v7" feature of the "%{crate}" crate.
%files -n %{name}+v7-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+v8-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+v8-devel %{_description}
This package contains library source intended for building other packages which
use the "v8" feature of the "%{crate}" crate.
%files -n %{name}+v8-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Nov 20 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.5.0-1
- Rebuilt for MSVSphere 9.2
* Thu Oct 19 2023 Fabio Valentini <decathorpe@gmail.com> - 1.5.0-1
- Update to version 1.5.0; Fixes RHBZ#2244855
* Sat Jul 29 2023 Fabio Valentini <decathorpe@gmail.com> - 1.4.1-1
- Update to version 1.4.1; Fixes RHBZ#2223255
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sat Jul 15 2023 Fabio Valentini <decathorpe@gmail.com> - 1.4.0-1
- Update to version 1.4.0; Fixes RHBZ#2217791
* Fri Jun 23 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.4-1
- Update to version 1.3.4; Fixes RHBZ#2214494
* Wed May 17 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.3-1
- Update to version 1.3.3; Fixes RHBZ#2203814
* Sun Apr 30 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.2-1
- Update to version 1.3.2; Fixes RHBZ#2192075
* Fri Apr 14 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.1-1
- Update to version 1.3.1; Fixes RHBZ#2185419
* Fri Feb 03 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.0-1
- Update to version 1.3.0; Fixes RHBZ#2166236
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Dec 10 2022 Fabio Valentini <decathorpe@gmail.com> - 1.2.2-1
- Update to version 1.2.2; Fixes RHBZ#2142704
* Tue Oct 11 2022 Fabio Valentini <decathorpe@gmail.com> - 1.2.1-1
- Update to version 1.2.1; Fixes RHBZ#2133232
* Sat Oct 08 2022 Fabio Valentini <decathorpe@gmail.com> - 1.2.0-1
- Update to version 1.2.0; Fixes RHBZ#2133131
* Mon Aug 08 2022 Fabio Valentini <decathorpe@gmail.com> - 1.1.2-1
- Update to version 1.1.2; Fixes RHBZ#2095908
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Mon Jun 06 2022 Fabio Valentini <decathorpe@gmail.com> - 1.1.1-1
- Update to version 1.1.1; Fixes RHBZ#2076870
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Mon Jan 11 2021 Fabio Valentini <decathorpe@gmail.com> - 0.8.2-1
- Update to version 0.8.2.
- Fixes RHBZ#1914753
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Jan 16 2020 Josh Stone <jistone@redhat.com> - 0.8.1-2
- Bump to md5 0.7
* Thu Jan 16 2020 Josh Stone <jistone@redhat.com> - 0.8.1-1
- Update to 0.8.1
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sat Jun 22 10:18:57 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-2
- Regenerate
* Fri Mar 29 15:50:41 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-1
- Update to 0.7.4
* Mon Mar 25 08:29:16 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.3-1
- Update to 0.7.3
* Sun Mar 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.2-3
- Do not pull optional dependencies
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Jan 29 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.2-1
- Update to 0.7.2
* Tue Dec 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-3
- Bump rand, md5 to 0.6
* Sat Dec 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-2
- Run tests in infrastructure
* Tue Nov 20 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-1
- Update to 0.7.1
* Fri Nov 02 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.5-3
- Adapt to new packaging
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri May 25 2018 Josh Stone <jistone@redhat.com> - 0.6.5-1
- Update to 0.6.5
* Thu May 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.4-1
- Update to 0.6.4
* Thu Apr 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.3-1
- Update to 0.6.3
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-4
- Rebuild for rust-packaging v5
* Sun Jan 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-3
- Add implicit cargo features
* Sun Dec 31 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-2
- Bump rand to 0.4
- Bump sha1 to 0.4
* Sat Dec 02 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-1
- Initial package
Loading…
Cancel
Save