Bump rand to 0.4

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent a8f78572c1
commit 98eb340eb3

@ -6,19 +6,22 @@
Name: rust-%{crate}
Version: 0.5.1
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Library to generate and parse UUIDs
License: MIT or ASL 2.0
URL: https://crates.io/crates/uuid
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump rand to 0.4, https://github.com/rust-lang-nursery/uuid/pull/109
Patch0: uuid-0.5.1-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(md5) >= 0.3.0 with crate(md5) < 0.4.0)
BuildRequires: (crate(rand) >= 0.3.0 with crate(rand) < 0.4.0)
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(rustc-serialize) >= 0.3.0 with crate(rustc-serialize) < 0.4.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: (crate(sha1) >= 0.2.0 with crate(sha1) < 0.3.0)
@ -57,5 +60,8 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Sun Dec 31 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-2
- Bump rand to 0.4
* Sat Dec 02 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-1
- Initial package

@ -0,0 +1,11 @@
--- uuid-0.5.1/Cargo.toml 2017-06-30T08:40:30+02:00
+++ uuid-0.5.1/Cargo.toml 2017-12-31T18:33:06.222429+01:00
@@ -18,7 +18,7 @@
[dependencies]
rustc-serialize = { version = "0.3", optional = true }
serde = { version = "1.0", optional = true }
-rand = { version = "0.3", optional = true }
+rand = { version = "0.4", optional = true }
sha1 = { version = "0.2", optional = true }
md5 = { version = "0.3", optional = true }
Loading…
Cancel
Save