Update to version 1.5.0; Fixes RHBZ#2244855

epel9
Fabio Valentini 1 year ago
parent adcd6307fa
commit 69c951c13e
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -20,3 +20,4 @@
/uuid-1.3.4.crate
/uuid-1.4.0.crate
/uuid-1.4.1.crate
/uuid-1.5.0.crate

@ -1,18 +1,18 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate uuid
Name: rust-uuid
Version: 1.4.1
Version: 1.5.0
Release: %autorelease
Summary: Library to generate and parse UUIDs
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/uuid
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
# Automatically generated patch to strip dependencies and normalize metadata
Patch: uuid-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused optional dependency for borsh support
@ -20,7 +20,7 @@ Patch: uuid-fix-metadata-auto.diff
# * drop internal-only features
Patch: uuid-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A library to generate and parse UUIDs.}
@ -82,6 +82,18 @@ use the "atomic" feature of the "%{crate}" crate.
%files -n %{name}+atomic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytemuck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytemuck-devel %{_description}
This package contains library source intended for building other packages which
use the "bytemuck" feature of the "%{crate}" crate.
%files -n %{name}+bytemuck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-rng-devel
Summary: %{summary}
BuildArch: noarch
@ -299,7 +311,7 @@ use the "v8" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires

@ -1 +1 @@
SHA512 (uuid-1.4.1.crate) = 95914b62948941e9dcda7b66b932088b328a23286d163449a72961874f4a856db6db1d60a125e56cd1d7b1c00391485a45520852ea49bd8e5a7b8cae8ecf8b96
SHA512 (uuid-1.5.0.crate) = 42494524d5e837558d6254adbc5749ebabfca018b3d41b47a5ebf5925e37005e02ebd1a20a1cfc59cdfcfb5bb87656a7ef5e1383681363c3ae3df2ca3adea3b5

@ -1,6 +1,6 @@
--- uuid-1.4.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.4.1/Cargo.toml 2023-07-29T14:55:39.956040+00:00
@@ -178,17 +178,6 @@
--- uuid-1.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.5.0/Cargo.toml 2023-10-19T14:36:57.156620+00:00
@@ -184,17 +184,6 @@
]
v8 = []
@ -18,3 +18,8 @@
[badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid"
@@ -203,3 +192,4 @@
[badges.maintenance]
status = "actively-developed"
+

@ -1,6 +1,6 @@
--- uuid-1.4.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.4.1/Cargo.toml 2023-07-29T14:56:16.540197+00:00
@@ -84,10 +84,6 @@
--- uuid-1.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.5.0/Cargo.toml 2023-10-19T14:37:41.348829+00:00
@@ -85,10 +85,6 @@
default-features = false
package = "atomic"
@ -8,15 +8,15 @@
-version = "0.10.3"
-optional = true
-
[dependencies.getrandom]
version = "0.2"
optional = true
@@ -119,20 +115,6 @@
[dependencies.bytemuck]
version = "1.14.0"
features = ["derive"]
@@ -125,20 +121,6 @@
version = "2"
optional = true
-[dependencies.uuid-macro-internal]
-version = "1.4.1"
-version = "1.5.0"
-optional = true
-package = "uuid-macro-internal"
-
@ -32,7 +32,7 @@
[dev-dependencies.bincode]
version = "1.0"
@@ -157,12 +139,6 @@
@@ -163,12 +145,6 @@
"rng",
"rand",
]

Loading…
Cancel
Save