Update to version 1.3.1; Fixes RHBZ#2185419

epel9
Fabio Valentini 2 years ago
parent d43a295ce8
commit 4f4749bc2b
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -14,3 +14,4 @@
/uuid-1.2.1.crate
/uuid-1.2.2.crate
/uuid-1.3.0.crate
/uuid-1.3.1.crate

@ -1,3 +0,0 @@
# rust-uuid
The rust-uuid package

@ -1,11 +1,11 @@
# Generated by rust2rpm 23
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate uuid
Name: rust-uuid
Version: 1.3.0
Version: 1.3.1
Release: %autorelease
Summary: Library to generate and parse UUIDs
@ -14,11 +14,15 @@ URL: https://crates.io/crates/uuid
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: uuid-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop WASM-specific features and dependencies
# * drop internal-only features
Patch: uuid-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Library to generate and parse UUIDs.}
A library to generate and parse UUIDs.}
%description %{_description}

@ -1,7 +0,0 @@
[DEFAULT]
unwanted-features =
wasm-bindgen
zerocopy
js
macro-diagnostics
uuid-macro-internal

@ -1 +1 @@
SHA512 (uuid-1.3.0.crate) = 0914998dc2d516c215b1309a2527af557cecfbbd57f793d416d7ce6520b75dac60951d7e0951d10f251e8bb66733615e502c946acdaa503aba2fc0e3d4a874da
SHA512 (uuid-1.3.1.crate) = 53f2782cf4ded7bd84614d819e10979c3d60fb05fbbdf6adc8d282ec6a89be829feccc38fff29203260a4b267f332243cbb4d940d3dd83fc210716bf46e8ba44

@ -1,5 +1,5 @@
--- uuid-1.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
--- uuid-1.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.3.1/Cargo.toml 2023-04-14T21:34:43.080760+00:00
@@ -173,17 +173,6 @@
]
v8 = []
@ -12,7 +12,7 @@
-version = "0.3"
-
-[target."cfg(windows)".dev-dependencies.windows-sys]
-version = "0.45.0"
-version = "0.48.0"
-features = ["Win32_System_Com"]
-
[badges.is-it-maintained-issue-resolution]

@ -0,0 +1,36 @@
--- uuid-1.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.3.1/Cargo.toml 2023-04-14T21:36:00.861013+00:00
@@ -114,20 +114,6 @@
version = "2"
optional = true
-[dependencies.uuid-macro-internal]
-version = "1.3.1"
-optional = true
-package = "uuid-macro-internal"
-
-[dependencies.wasm-bindgen]
-version = "0.2"
-optional = true
-package = "wasm-bindgen"
-
-[dependencies.zerocopy]
-version = "0.6"
-optional = true
-
[dev-dependencies.bincode]
version = "1.0"
@@ -152,12 +138,6 @@
"rng",
"rand",
]
-js = [
- "wasm-bindgen",
- "getrandom",
- "getrandom/js",
-]
-macro-diagnostics = ["uuid-macro-internal"]
md5 = ["md-5"]
rng = ["getrandom"]
sha1 = ["sha1_smol"]
Loading…
Cancel
Save