Update to version 2.4.0; Fixes RHBZ#2212332

epel9
Fabio Valentini 2 years ago
parent bac626c2ee
commit af2e55f746
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -8,3 +8,4 @@
/url-2.2.1.crate
/url-2.2.2.crate
/url-2.3.1.crate
/url-2.4.0.crate

@ -1,3 +0,0 @@
# rust-url
The rust-url package

@ -1,11 +1,11 @@
# Generated by rust2rpm 23
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate url
Name: rust-url
Version: 2.3.1
Version: 2.4.0
Release: %autorelease
Summary: URL library for Rust, based on the WHATWG URL Standard
@ -50,18 +50,6 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+debugger_visualizer-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+debugger_visualizer-devel %{_description}
This package contains library source intended for building other packages which
use the "debugger_visualizer" feature of the "%{crate}" crate.
%files -n %{name}+debugger_visualizer-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+expose_internals-devel
Summary: %{summary}
BuildArch: noarch

@ -1 +1 @@
SHA512 (url-2.3.1.crate) = 8224010bef067574481e5d84100d944782d52b49db7c396ae2b4dfc145ed58769c15440d97a0fed4d2f9857592a8601417cc5b1bdea959c47a3e7a1f7182ed0d
SHA512 (url-2.4.0.crate) = acef524d2c00d2fd68ec6385ca2a44b740f60724256750d8b0ea609dec7f9d59303069f315f04a5205925a27274ec7709f3818a2237ea0023845e9a12905694c

@ -1,8 +1,8 @@
--- url-2.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ url-2.3.1/Cargo.toml 2022-12-12T17:58:13.308623+00:00
@@ -36,12 +36,6 @@
license = "MIT OR Apache-2.0"
repository = "https://github.com/servo/rust-url"
--- url-2.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ url-2.4.0/Cargo.toml 2023-07-13T22:38:17.667510+00:00
@@ -42,17 +42,6 @@
[package.metadata.playground]
features = ["serde"]
-[[test]]
-name = "debugger_visualizer"
@ -10,10 +10,15 @@
-test = false
-required-features = ["debugger_visualizer"]
-
[[bench]]
name = "parse_url"
path = "benches/parse_url.rs"
@@ -64,12 +58,6 @@
-[[bench]]
-name = "parse_url"
-path = "benches/parse_url.rs"
-harness = false
-
[dependencies.form_urlencoded]
version = "1.2.0"
@@ -70,17 +59,10 @@
[dev-dependencies.bencher]
version = "0.1"
@ -26,3 +31,8 @@
[dev-dependencies.serde_json]
version = "1.0"
[features]
-debugger_visualizer = []
default = []
expose_internals = []

Loading…
Cancel
Save