Update to version 2.4.1; Fixes RHBZ#2235305

epel9
Fabio Valentini 2 years ago
parent 6622ff3381
commit 36781a57cb
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -9,3 +9,4 @@
/url-2.2.2.crate
/url-2.3.1.crate
/url-2.4.0.crate
/url-2.4.1.crate

@ -5,16 +5,13 @@
%global crate url
Name: rust-url
Version: 2.4.0
Version: 2.4.1
Release: %autorelease
Summary: URL library for Rust, based on the WHATWG URL Standard
License: MIT OR Apache-2.0
URL: https://crates.io/crates/url
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * remove debugger_test and debugger_test_parser dev-dependencies
Patch: url-fix-metadata.diff
BuildRequires: rust-packaging >= 21
@ -35,7 +32,6 @@ use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
@ -76,8 +72,6 @@ use the "serde" feature of the "%{crate}" crate.
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# drop tests that require connecting a debugger to the test runner
rm tests/debugger_visualizer.rs
%cargo_prep
%generate_buildrequires

@ -0,0 +1,4 @@
[DEFAULT]
summary = URL library for Rust, based on the WHATWG URL Standard
unwanted-features =
debugger_visualizer

@ -1 +1 @@
SHA512 (url-2.4.0.crate) = acef524d2c00d2fd68ec6385ca2a44b740f60724256750d8b0ea609dec7f9d59303069f315f04a5205925a27274ec7709f3818a2237ea0023845e9a12905694c
SHA512 (url-2.4.1.crate) = ff2aed100e405f4474e17dcc01d59b63460e7a8babeb7cdcf9df6c1c65216c425e24d557f76c7097702b2befc381656107bef755ce929089b52a3901c46aa185

@ -1,38 +1,9 @@
--- url-2.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ url-2.4.0/Cargo.toml 2023-07-13T22:38:17.667510+00:00
@@ -42,17 +42,6 @@
[package.metadata.playground]
features = ["serde"]
-[[test]]
-name = "debugger_visualizer"
-path = "tests/debugger_visualizer.rs"
-test = false
-required-features = ["debugger_visualizer"]
-
-[[bench]]
-name = "parse_url"
-path = "benches/parse_url.rs"
-harness = false
-
[dependencies.form_urlencoded]
version = "1.2.0"
@@ -70,17 +59,10 @@
[dev-dependencies.bencher]
version = "0.1"
-[dev-dependencies.debugger_test]
-version = "0.1"
-
-[dev-dependencies.debugger_test_parser]
-version = "0.1"
-
[dev-dependencies.serde_json]
--- url-2.4.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ url-2.4.1/Cargo.toml 2023-08-28T16:01:00.024105+00:00
@@ -63,6 +63,5 @@
version = "1.0"
[features]
-debugger_visualizer = []
default = []
expose_internals = []

Loading…
Cancel
Save