Update to version 2.3.1; Fixes RHBZ#2124906

epel9
Fabio Valentini 2 years ago
parent 436b29fe73
commit 1496c4ee04
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -7,3 +7,4 @@
/url-2.2.0.crate
/url-2.2.1.crate
/url-2.2.2.crate
/url-2.3.1.crate

@ -1,25 +1,22 @@
# Generated by rust2rpm 17
# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}
%global crate url
Name: rust-%{crate}
Version: 2.2.2
Name: rust-url
Version: 2.3.1
Release: %autorelease
Summary: URL library for Rust, based on the WHATWG URL Standard
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/url
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * remove debugger_test and debugger_test_parser dev-dependencies
Patch: url-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
URL library for Rust, based on the WHATWG URL Standard.}
@ -32,12 +29,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -45,11 +44,35 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+debugger_visualizer-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+debugger_visualizer-devel %{_description}
This package contains library source intended for building other packages which
use the "debugger_visualizer" feature of the "%{crate}" crate.
%files -n %{name}+debugger_visualizer-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+expose_internals-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+expose_internals-devel %{_description}
This package contains library source intended for building other packages which
use the "expose_internals" feature of the "%{crate}" crate.
%files -n %{name}+expose_internals-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
@ -57,14 +80,16 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# drop tests that require connecting a debugger to the test runner
rm tests/debugger_visualizer.rs
%cargo_prep
%generate_buildrequires

@ -1 +1 @@
SHA512 (url-2.2.2.crate) = f9b6ad99d69ff303283b3fd9e98945fbd6cb411a3d141badcbb3a0566723a451375e6dd5d5357e3eb7a1b5b1ee5756a2347c43817db2de6fe35b9004b090e077
SHA512 (url-2.3.1.crate) = 8224010bef067574481e5d84100d944782d52b49db7c396ae2b4dfc145ed58769c15440d97a0fed4d2f9857592a8601417cc5b1bdea959c47a3e7a1f7182ed0d

@ -0,0 +1,28 @@
--- url-2.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ url-2.3.1/Cargo.toml 2022-12-12T17:58:13.308623+00:00
@@ -36,12 +36,6 @@
license = "MIT OR Apache-2.0"
repository = "https://github.com/servo/rust-url"
-[[test]]
-name = "debugger_visualizer"
-path = "tests/debugger_visualizer.rs"
-test = false
-required-features = ["debugger_visualizer"]
-
[[bench]]
name = "parse_url"
path = "benches/parse_url.rs"
@@ -64,12 +58,6 @@
[dev-dependencies.bencher]
version = "0.1"
-[dev-dependencies.debugger_test]
-version = "0.1"
-
-[dev-dependencies.debugger_test_parser]
-version = "0.1"
-
[dev-dependencies.serde_json]
version = "1.0"
Loading…
Cancel
Save