Update to version 0.5.0; Fixes RHBZ#2112550

epel9
Fabio Valentini 2 years ago
parent 6db215a5e1
commit b533a4083d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,3 +0,0 @@
# rust-universal-hash
The rust-universal-hash package

@ -1,28 +1,26 @@
# Generated by rust2rpm 13
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate universal-hash
Name: rust-%{crate}
Version: 0.4.0
Name: rust-universal-hash
Version: 0.5.0
Release: %autorelease
Summary: Trait for universal hash functions
Summary: Traits which describe the functionality of universal hash functions
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/universal-hash
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * relax stricter-than-SemVer subtle dependency
Patch: universal-hash-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Trait for universal hash functions.}
Traits which describe the functionality of universal hash functions
(UHFs).}
%description %{_description}
@ -32,13 +30,15 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -46,11 +46,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -58,11 +58,11 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (universal-hash-0.4.0.crate) = 572b1760b04d61491ce468b79d3afd1257a67ea0d33f21a81dc0efe32c6a31d4f85915e927806f06b8deaf0bcb609950afa4fa1759e0f276746d75b00a8c703a
SHA512 (universal-hash-0.5.0.crate) = 61e51323e213efbc94cfe9ceab59f49dcbc5bea05f47efdac6b939cd46ff74abd2f501656da67e670206cfaf3f5109251291f73b163538ef3148f4bbeb05346c

@ -0,0 +1,11 @@
--- universal-hash-0.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ universal-hash-0.5.0/Cargo.toml 2023-03-16T16:44:08.548270+00:00
@@ -41,7 +41,7 @@
version = "0.1.6"
[dependencies.subtle]
-version = "=2.4"
+version = "2.4"
default-features = false
[features]
Loading…
Cancel
Save