You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-unicode-xid/rust-unicode-xid.spec

101 lines
2.4 KiB

# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}
%global crate unicode-xid
Name: rust-unicode-xid
Version: 0.2.4
Release: %autorelease
Summary: Check characters for the XID_Start and XID_Continue properties
License: MIT OR Apache-2.0
URL: https://crates.io/crates/unicode-xid
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
Patch: unicode-xid-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Determine whether characters have the XID_Start or XID_Continue properties
according to Unicode Standard Annex #31.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bench-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bench-devel %{_description}
This package contains library source intended for building other packages which
use the "bench" feature of the "%{crate}" crate.
%files -n %{name}+bench-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+no_std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+no_std-devel %{_description}
This package contains library source intended for building other packages which
use the "no_std" feature of the "%{crate}" crate.
%files -n %{name}+no_std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog