Adapt to new packaging

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent ac6312becc
commit e67cc74e13
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -7,34 +7,67 @@
Name: rust-%{crate}
Version: 0.1.0
Release: 6%{?dist}
Release: 7%{?dist}
Summary: Determine whether characters have XID_Start/XID_Continue properties
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/unicode-xid
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Exclude scripts/*, https://github.com/unicode-rs/unicode-xid/pull/8
Patch0: unicode-xid-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
%description
%{summary}.
%global _description \
Determine whether characters have the XID_Start or XID_Continue properties\
according to Unicode Standard Annex #31.
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
Determine whether characters have the XID_Start or XID_Continue
properties according to Unicode Standard Annex #31.
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE COPYRIGHT
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+no_std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+no_std-devel %{_description}
This package contains library source intended for building other packages
which use %{crate} from crates.io.
which use "no_std" feature of "%{crate}" crate.
%files -n %{name}+no_std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
rm -vrf .gitignore .travis.yml scripts
%cargo_prep
%build
@ -48,12 +81,10 @@ rm -vrf .gitignore .travis.yml scripts
%cargo_test
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE COPYRIGHT
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Fri Oct 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.0-7
- Adapt to new packaging
* Sun Oct 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.0-6
- Run tests in infrastructure

@ -0,0 +1,11 @@
--- unicode-xid-0.1.0/Cargo.toml 2017-05-08T19:43:03+02:00
+++ unicode-xid-0.1.0/Cargo.toml 2018-10-26T20:18:03.309081+02:00
@@ -18,7 +18,7 @@
Unicode Standard Annex #31.
"""
-exclude = [ "target/*", "Cargo.lock" ]
+exclude = [ "target/*", "Cargo.lock", "/scripts/*" ]
[features]
default = []
Loading…
Cancel
Save