Update to version 0.2.3; Fixes RHBZ#2080970

epel9^2
Fabio Valentini 3 years ago
parent 1c0365d822
commit d9344869e7
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/unicode-xid-0.2.0.crate
/unicode-xid-0.2.1.crate
/unicode-xid-0.2.2.crate
/unicode-xid-0.2.3.crate

@ -1,25 +1,25 @@
# Generated by rust2rpm 19
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate unicode-xid
Name: rust-%{crate}
Version: 0.2.2
Version: 0.2.3
Release: %autorelease
Summary: Determine whether characters have the XID_Start or XID_Continue properties according to Unicode Standard Annex #31
Summary: Check characters for the XID_Start and XID_Continue properties
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/unicode-xid
Source: %{crates_source}
# Initial patched metadata
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
Patch0: unicode-xid-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Determine whether characters have the XID_Start or XID_Continue properties
@ -34,12 +34,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use "%{crate}" crate.
use the "%{crate}" crate.
%files devel
%license COPYRIGHT LICENSE-APACHE LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -48,10 +50,10 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use "the default" feature of the "%{crate}" crate.
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bench-devel
Summary: %{summary}
@ -60,10 +62,10 @@ BuildArch: noarch
%description -n %{name}+bench-devel %{_description}
This package contains library source intended for building other packages which
use "the bench" feature of the "%{crate}" crate.
use the "bench" feature of the "%{crate}" crate.
%files -n %{name}+bench-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+no_std-devel
Summary: %{summary}
@ -72,10 +74,10 @@ BuildArch: noarch
%description -n %{name}+no_std-devel %{_description}
This package contains library source intended for building other packages which
use "the no_std" feature of the "%{crate}" crate.
use the "no_std" feature of the "%{crate}" crate.
%files -n %{name}+no_std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (unicode-xid-0.2.2.crate) = 92ffd0dd34e3ca235ecf110b38c447d3ec1faa23d76c112457f28d432f92fa6b5f428bc5e1bfd278f361f55426dd96e19ecb0d3eff6cf250892f069c52bd89a8
SHA512 (unicode-xid-0.2.3.crate) = 2adea0c8447c9450be34859f2b2e2b87a61b5e313685da994d21bc24a96dd94088f3320bcdb8d20466a3fdafb0bc0375823f0c28ec0077c9c42a9818f66ac1f5

@ -0,0 +1,12 @@
--- unicode-xid-0.2.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ unicode-xid-0.2.3/Cargo.toml 2022-05-13T10:47:03.590038+00:00
@@ -42,9 +42,6 @@
name = "xid"
harness = false
-[dev-dependencies.criterion]
-version = "0.3"
-
[features]
bench = []
default = []
Loading…
Cancel
Save