You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-unicode-width0.1/rust-unicode-width0.1.spec

99 lines
2.4 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate unicode-width
Name: rust-unicode-width0.1
Version: 0.1.14
Release: %autorelease
Summary: Determine displayed width of 'char' and 'str' types
License: MIT OR Apache-2.0
URL: https://crates.io/crates/unicode-width
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * exclude scripts that are only useful for upstream development
Patch: unicode-width-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Determine displayed width of `char` and `str` types according to Unicode
Standard Annex #11 rules.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cjk-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cjk-devel %{_description}
This package contains library source intended for building other packages which
use the "cjk" feature of the "%{crate}" crate.
%files -n %{name}+cjk-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+no_std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+no_std-devel %{_description}
This package contains library source intended for building other packages which
use the "no_std" feature of the "%{crate}" crate.
%files -n %{name}+no_std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog